iproute2: add ip-tiny, ip-full as alternatives of /sbin/ip
[openwrt/staging/yousong.git] / include / host-build.mk
index 6a335fcbc3b1fe62e4b18f7e2f7f1b590e8b1c1c..c8477e1ddf7bd8b51a9a813bdcc1b5c85274c9d9 100644 (file)
@@ -19,7 +19,6 @@ else
 HOST_JOBS?=$(if $(HOST_BUILD_PARALLEL),$(HOST_MAKE_J),-j1)
 endif
 
-include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/unpack.mk
 include $(INCLUDE_DIR)/depends.mk
 
@@ -108,7 +107,7 @@ define Host/Compile
 endef
 
 define Host/Install/Default
-       $(_SINGLE)$(MAKE) -C $(HOST_BUILD_DIR) install
+       $(call Host/Compile/Default,install)
 endef
 
 define Host/Install
@@ -176,15 +175,21 @@ ifndef DUMP
       $(t): host-$(t)
       .$(t): .host-$(t)
     )
+    clean-build: host-clean-build
   endif
 
   $(_host_target)host-prepare: $(HOST_STAMP_PREPARED)
   $(_host_target)host-configure: $(HOST_STAMP_CONFIGURED)
   $(_host_target)host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
-  host-clean: FORCE
+  host-install: host-compile
+
+  host-clean-build: FORCE
+       rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_BUILT)
+
+  host-clean: host-clean-build
        $(call Host/Clean)
        $(call Host/Uninstall)
-       rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_INSTALLED) $(HOST_STAMP_BUILT)
+       rm -rf $(HOST_STAMP_INSTALLED)
 
     ifneq ($(CONFIG_AUTOREMOVE),)
       host-compile: