kernel: bump 6.1 to 6.1.37
[openwrt/staging/hauke.git] / include / download.mk
index 9ff71540f756ff5e6980a86e944917d7e05e601b..9ab0b6c08fca7b737b62f7db9ad817b438b8b66e 100644 (file)
@@ -20,6 +20,7 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
 
 # Export options for download.pl
 export DOWNLOAD_CHECK_CERTIFICATE:=$(CONFIG_DOWNLOAD_CHECK_CERTIFICATE)
+export DOWNLOAD_TOOL_CUSTOM:=$(CONFIG_DOWNLOAD_TOOL_CUSTOM)
 
 define dl_method_git
 $(if $(filter https://github.com/% git://github.com/%,$(1)),github_archive,git)
@@ -186,7 +187,7 @@ define DownloadMethod/svn
                svn export --non-interactive --trust-server-cert -r$(VERSION) $(URL) $(SUBDIR) || \
                svn export --non-interactive -r$(VERSION) $(URL) $(SUBDIR) ) && \
                echo "Packing checkout..." && \
-               export TAR_TIMESTAMP="" && \
+               export TAR_TIMESTAMP="`svn info -r$(VERSION) --show-item last-changed-date $(URL)`" && \
                $(call dl_tar_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
                mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/ && \
                rm -rf $(SUBDIR); \