SVN checkouts should be made non-interactive, so that https repositories with auto...
[openwrt/staging/lynxis.git] / include / download.mk
index 0558d4979ec8a562b7f9184894d93606c31e6594..74986be598e84e31d331771811e7c10a8d0373cd 100644 (file)
@@ -67,7 +67,7 @@ define DownloadMethod/svn
                cd $(TMP_DIR)/dl && \
                rm -rf $(SUBDIR) && \
                [ \! -d $(SUBDIR) ] && \
-               svn co -r$(VERSION) $(URL) $(SUBDIR) && \
+               svn co --non-interactive -r$(VERSION) $(URL) $(SUBDIR) && \
                find $(SUBDIR) -name .svn | xargs rm -rf && \
                echo "Packing checkout..." && \
                $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \