kernel: bump 5.15 to 5.15.128
[openwrt/staging/hauke.git] / include / autotools.mk
index f659bac3c5bedae41b508415ce6df401d5ea040b..d0e4b3642f5371a7418578e9eb761a1ba5461966 100644 (file)
@@ -23,7 +23,10 @@ AM_TOOL_PATHS:= \
        LIBTOOLIZE=$(STAGING_DIR_HOST)/bin/libtoolize \
        LIBTOOL=$(STAGING_DIR_HOST)/bin/libtool \
        M4=$(STAGING_DIR_HOST)/bin/m4 \
-       AUTOPOINT=true
+       AUTOPOINT=true \
+       GTKDOCIZE=true
+
+AM_TOOL_PATHS_FAKE:=$(subst = ,=,$(patsubst "%,"$(TRUE)",$(subst =,= ",$(AM_TOOL_PATHS))))
 
 # 1: build dir
 # 2: remove files
@@ -123,13 +126,6 @@ ifneq ($(filter libtool-abiver,$(PKG_FIXUP)),)
   Hooks/Configure/Post += set_libtool_abiver
 endif
 
-ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
- ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
-  Hooks/Configure/Pre += autoreconf_target
- endif
-endif
-
 ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
   ifeq ($(filter autoreconf,$(Hooks/Configure/Pre)),)
     Hooks/Configure/Pre += autoreconf_target
@@ -165,12 +161,6 @@ ifneq ($(filter libtool,$(HOST_FIXUP)),)
  endif
 endif
 
-ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
- ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
-  Hooks/HostConfigure/Pre += autoreconf_host
- endif
-endif
-
 ifneq ($(filter autoreconf,$(HOST_FIXUP)),)
   ifeq ($(filter autoreconf,$(Hooks/HostConfigure/Pre)),)
     Hooks/HostConfigure/Pre += autoreconf_host