libnftnl: bump to 1.1.5
[openwrt/staging/rmilecki.git] / Makefile
index 65ee10a84b8d57c5bfed7047f0ed114a78190df1..fd705a37ad827cb72ec9a7f85d794a1d4e9f8158 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -60,6 +60,7 @@ clean: FORCE
 dirclean: clean
        rm -rf $(STAGING_DIR_HOST) $(STAGING_DIR_HOSTPKG) $(TOOLCHAIN_DIR) $(BUILD_DIR_BASE)/host $(BUILD_DIR_BASE)/hostpkg $(BUILD_DIR_TOOLCHAIN)
        rm -rf $(TMP_DIR)
+       $(MAKE) -C $(TOPDIR)/scripts/config clean
 
 ifndef DUMP_TARGET_DB
 $(BUILD_DIR)/.prepared: Makefile
@@ -100,9 +101,12 @@ diffconfig: FORCE
        mkdir -p $(BIN_DIR)
        $(SCRIPT_DIR)/diffconfig.sh > $(BIN_DIR)/config.buildinfo
 
-prepare: .config $(tools/stamp-compile) $(toolchain/stamp-compile)
+buildinfo: FORCE
        $(_SINGLE)$(SUBMAKE) -r diffconfig buildversion feedsversion
 
+prepare: .config $(tools/stamp-compile) $(toolchain/stamp-compile)
+       $(_SINGLE)$(SUBMAKE) -r buildinfo
+
 world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
        $(_SINGLE)$(SUBMAKE) -r package/index
        $(_SINGLE)$(SUBMAKE) -r checksum