Fix wget-nossl variant by disabling ntlm support (bug 15718 and 15731)
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 29 Apr 2014 19:38:23 +0000 (19:38 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 29 Apr 2014 19:38:23 +0000 (19:38 +0000)
Fix wget-nossl variant by disabling ntlm support in wget-nossl.

https://dev.openwrt.org/ticket/15718#comment:13
https://dev.openwrt.org/ticket/15731

In wget 1.15 the ntlm support requires either ssl or libnettle library.
Check-in behind the change:
http://git.savannah.gnu.org/cgit/wget.git/commit/?id=c19d76c02483f070beb688d6fe6f5fafb5674a08

ssl is not present in the nossl variant and developers prefer to keep the
nossl variant small, so the natural alternative is to disable ntlm support in
the nossl variant, as a configure option for that purpose exists and a simple
change in Openwrt Makefile is enough.

Tested with ar71xx/wndr3700.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
SVN-Revision: 40595

net/wget/Makefile

index bea4523bee0720df3dcc5affa9ad9bfff2618bf6..8acd3b90ae08d583280f1287f47758e8d972e9fa 100644 (file)
@@ -76,6 +76,7 @@ endif
 
 ifeq ($(BUILD_VARIANT),nossl)
        CONFIGURE_ARGS+= \
+               --disable-ntlm \
                --without-ssl
 endif