ipq40xx: Fix board-2.bin package name for Plasma Cloud PA2200
authorSven Eckelmann <sven@narfation.org>
Sat, 11 Sep 2021 06:33:30 +0000 (08:33 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sun, 19 Sep 2021 18:01:18 +0000 (20:01 +0200)
The board data file for the Plasma Cloud PA2200 is not part of the default
board-2.bin which is shipped by ath10k-board-qca4019. A typo in the device
package name resulted in a not correctly selected package for the device
specific board-2.bin. The wifi driver has therefore loaded the wrong
calibration information into the wifi chip.

Fixes: 4871fd2616ac ("ipq40xx: add support for Plasma Cloud PA2200")
Signed-off-by: Sven Eckelmann <sven@narfation.org>
(cherry picked from commit c7e9335e4c23f3bd074cb2b215a289b8b75f319c)

target/linux/ipq40xx/image/generic.mk

index 099f7f831539dd1490675be10a3ce618a64be70e..49aa202e623ded19eb4760d028303f188b34224e 100644 (file)
@@ -695,7 +695,7 @@ define Device/plasmacloud_pa2200
        IMAGES += factory.bin
        IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA2200
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
-       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-plasmacloud-pa2200
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-plasmacloud_pa2200
 endef
 TARGET_DEVICES += plasmacloud_pa2200