ath79: image: allow changing kernel option in mkubntimage
authorTomasz Maciej Nowak <tmn505@gmail.com>
Wed, 16 Aug 2023 18:28:01 +0000 (20:28 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 19 Nov 2023 13:58:44 +0000 (14:58 +0100)
Backport didn't include changes to mkubntimage invocation, which allowed
to pass arguments. This in result produces broken routerstation factory
images, which have kernel embedded as kernel partition instead of LZMA
loader.

Fixes: #13260
Fixes: 8e09f9ffc3cc ("ath79: switch some RedBoot based devices to OKLI loader")
Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
target/linux/ath79/image/common-ubnt.mk

index 625f0b4f3f12c8efe4858cb9e22bcb61445d9bc7..76d6de000ba6039e627d3eb62b36de421a7a447a 100644 (file)
@@ -10,7 +10,7 @@ UBNT_REVISION := $(VERSION_DIST)-$(REVISION)
 define Build/mkubntimage
        -$(STAGING_DIR_HOST)/bin/mkfwimage -B $(UBNT_BOARD) \
                -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
-               -k $(IMAGE_KERNEL) -r $@ -o $@
+               -k $(if $(1),$(1),$(IMAGE_KERNEL)) -r $@ -o $@
 endef
 
 define Build/mkubntimage2