kernel: load device-mapper early on boot
authorDaniel Golle <daniel@makrotopia.org>
Sun, 3 Apr 2022 15:19:31 +0000 (16:19 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 5 Apr 2022 21:33:35 +0000 (23:33 +0200)
Previously commit openwrt/packages@3abb7cb ("lvm2: Added script and updated Makefile[...]")
couldn't actually work and allow rootfs_data to be stored on a LVM2 as
the necessary kernel modules had not been loaded at this point.
Fix this by loading device-mapper modules early at boot.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit 82f9ad6ab21ca4925278429a3e1b31d26c306d9f)

package/kernel/linux/modules/block.mk

index e5822d95d78bcb4606a1dcef200a84c3bb4fffc2..2be9ef0c649a24ce60e00414770f5a1bd4d2364e 100644 (file)
@@ -243,7 +243,7 @@ define KernelPackage/dm
     $(LINUX_DIR)/drivers/md/dm-log.ko \
     $(LINUX_DIR)/drivers/md/dm-mirror.ko \
     $(LINUX_DIR)/drivers/md/dm-region-hash.ko
-  AUTOLOAD:=$(call AutoLoad,30,dm-mod dm-log dm-region-hash dm-mirror dm-crypt)
+  AUTOLOAD:=$(call AutoLoad,30,dm-mod dm-log dm-region-hash dm-mirror dm-crypt,1)
 endef
 
 define KernelPackage/dm/description