kernel: bump 5.4 to 5.4.203
[openwrt/openwrt.git] / target / linux / generic / backport-5.4 / 080-wireguard-0040-crypto-lib-curve25519-re-add-selftests.patch
index e43d196a3b87509a31f5c3c246147b9947f4ab16..df2aa740a722978cba918676ea42fb45b3d7c573 100644 (file)
@@ -22,9 +22,9 @@ Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
 
 --- a/lib/crypto/Makefile
 +++ b/lib/crypto/Makefile
-@@ -36,4 +36,5 @@ libsha256-y                                  := sha256.o
+@@ -32,4 +32,5 @@ libblake2s-y += blake2s.o blake2s-generi
  ifneq ($(CONFIG_CRYPTO_MANAGER_DISABLE_TESTS),y)
- libblake2s-y                                  += blake2s-selftest.o
+ libblake2s-y += blake2s-selftest.o
  libchacha20poly1305-y                         += chacha20poly1305-selftest.o
 +libcurve25519-y                                       += curve25519-selftest.o
  endif