kernel: bump 5.4 to 5.4.203
[openwrt/openwrt.git] / target / linux / generic / backport-5.4 / 080-wireguard-0013-crypto-poly1305-move-core-routines-into-a-separate-l.patch
index 960300d2a5b016a693bd14658ed782acedc5448c..42d8d5cf56df67e64f1298e0b5428b84ff471a05 100644 (file)
@@ -477,7 +477,7 @@ Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
        tristate
 --- a/lib/crypto/Makefile
 +++ b/lib/crypto/Makefile
-@@ -13,5 +13,8 @@ libarc4-y                                    := arc4.o
+@@ -13,6 +13,9 @@ libarc4-y                                    := arc4.o
  obj-$(CONFIG_CRYPTO_LIB_DES)                  += libdes.o
  libdes-y                                      := des.o
  
@@ -486,6 +486,7 @@ Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
 +
  obj-$(CONFIG_CRYPTO_LIB_SHA256)                       += libsha256.o
  libsha256-y                                   := sha256.o
 --- /dev/null
 +++ b/lib/crypto/poly1305.c
 @@ -0,0 +1,158 @@