minisatip: Fix configure option for openssl
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Mar 2024 19:04:09 +0000 (20:04 +0100)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Sun, 17 Mar 2024 21:40:55 +0000 (22:40 +0100)
The configure option which depends on openSSL is named --disable-dvbca
and not --disable-dvbaes

This fixes the following warning:
configure: WARNING: unrecognized options: --disable-dependency-tracking, --disable-nls, --disable-dvbaes

When the option is not set configure will check if openssl is available
and compile against openssl if it find openssl. This breaks the build
because openssl is not defined as a package dependency.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
multimedia/minisatip/Makefile

index 04ea24cdc2f8458462582811a401983b9e82f377..002aea0270d82798418d0bb61e0fde18fc43e5ef 100644 (file)
@@ -48,7 +48,7 @@ endef
 
 CONFIGURE_ARGS += \
        --$(if $(CONFIG_BUILD_PATENTED),en,dis)able-dvbcsa \
-       --$(if $(CONFIG_MINISATIP_AES),en,dis)able-dvbaes \
+       --$(if $(CONFIG_MINISATIP_AES),en,dis)able-dvbca \
        --$(if $(CONFIG_MINISATIP_CLIENT),en,dis)able-satipc
 
 define Package/minisatip/install