golang: Update to 1.22.1 23475/head
authorZephyr Lykos <git@mochaa.ws>
Fri, 8 Mar 2024 04:35:07 +0000 (12:35 +0800)
committerZephyr Lykos <git@mochaa.ws>
Wed, 20 Mar 2024 09:25:09 +0000 (17:25 +0800)
Go 1.22.1 contains the following security fixes:

- CVE-2024-24783:
  crypto/x509: Verify panics on certificates with an unknown public key
  algorithm
- CVE-2023-45290
  net/http: memory exhaustion in Request.ParseMultipartForm
- CVE-2023-45289
  net/http, net/http/cookiejar: incorrect forwarding of sensitive headers
  and cookies on HTTP redirect
- CVE-2024-24785
  html/template: errors returned from MarshalJSON methods may break
  template escaping
- CVE-2024-24784
  net/mail: comments in display names are incorrectly handled

https://go.dev/doc/devel/release#go1.22.1
https://groups.google.com/g/golang-announce/c/5pwGVUPoMbg

Signed-off-by: Zephyr Lykos <git@mochaa.ws>
lang/golang/golang/Makefile

index f11594f69173ba0893353e6da09a10c139844296..8756dcf661998c9f0c235ab21ccd7686e06e4563 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 GO_VERSION_MAJOR_MINOR:=1.22
-GO_VERSION_PATCH:=0
+GO_VERSION_PATCH:=1
 
 PKG_NAME:=golang
 PKG_VERSION:=$(GO_VERSION_MAJOR_MINOR)$(if $(GO_VERSION_PATCH),.$(GO_VERSION_PATCH))
@@ -20,7 +20,7 @@ GO_SOURCE_URLS:=https://dl.google.com/go/ \
 
 PKG_SOURCE:=go$(PKG_VERSION).src.tar.gz
 PKG_SOURCE_URL:=$(GO_SOURCE_URLS)
-PKG_HASH:=4d196c3d41a0d6c1dfc64d04e3cc1f608b0c436bd87b7060ce3e23234e1f4d5c
+PKG_HASH:=79c9b91d7f109515a25fc3ecdaad125d67e6bdb54f6d4d98580f46799caea321
 
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
 PKG_LICENSE:=BSD-3-Clause