postfix: Fix enabling PCRE support
authorFelix Matouschek <felix@matouschek.org>
Mon, 27 Nov 2023 10:12:03 +0000 (11:12 +0100)
committerRosen Penev <rosenp@gmail.com>
Fri, 1 Dec 2023 19:24:34 +0000 (11:24 -0800)
After the change from PCRE to PCRE2 when enabling POSTFIX_PCRE the
resulting postfix build no longer reports pcre as an available module.
(postfconf -m). This is caused by using the wrong syntax for the
HAS_PCRE build flag (HAS_PCRE2 vs HAS_PCRE=2). This fixes the build flag
to use the correct syntax.

Signed-off-by: Felix Matouschek <felix@matouschek.org>
mail/postfix/Makefile

index 31371369219183850ceec542b3372d056cb2c2b4..5fbecf1258d358f3d043de7b704a99bdbdde0c43 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postfix
 PKG_VERSION:=3.8.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
@@ -172,7 +172,7 @@ ifdef CONFIG_POSTFIX_PGSQL
 endif
 
 ifdef CONFIG_POSTFIX_PCRE
-  CCARGS+=-DHAS_PCRE2 -I$(STAGING_DIR)/usr/include/
+  CCARGS+=-DHAS_PCRE=2 -I$(STAGING_DIR)/usr/include/
   AUXLIBS+=-L$(STAGING_DIR)/usr/lib -lpcre2-8
 else
   CCARGS+=-DNO_PCRE