lispmob: fix build with musl
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 19 Nov 2015 21:38:08 +0000 (22:38 +0100)
committerEtienne CHAMPETIER <champetier.etienne@gmail.com>
Sat, 2 Jul 2016 08:48:44 +0000 (08:48 +0000)
lispmob accesses the gnu members of struct udphdr like source and dest
and does not use the posix member names. Instead of using the correct
names just define this as _GNU_SOURCE.

[bump PKG_RELEASE]
Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
net/lispmob/Makefile
net/lispmob/patches/001-fix-musl-build.patch [new file with mode: 0644]

index 8c8531595bbaa1b4af7e025edbfaa66d34732d4c..b1776641ac8227f4f8b4710e50181aed44f84c3e 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=lispmob
 PKG_REV:=180aa39d338a00bb532e421de7f8513492cf2e8b
 PKG_VERSION:=0.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=git://github.com/LISPmob/lispmob.git
diff --git a/net/lispmob/patches/001-fix-musl-build.patch b/net/lispmob/patches/001-fix-musl-build.patch
new file mode 100644 (file)
index 0000000..82a482c
--- /dev/null
@@ -0,0 +1,31 @@
+--- a/lispd/lispd_output.c
++++ b/lispd/lispd_output.c
+@@ -26,6 +26,7 @@
+  *    Alberto Rodriguez Natal <arnatal@ac.upc.edu>
+  */
++#define _GNU_SOURCE 1
+ #include <assert.h>
+--- a/lispd/lispd_input.c
++++ b/lispd/lispd_input.c
+@@ -26,6 +26,7 @@
+  *    Alberto Rodriguez Natal <arnatal@ac.upc.edu>
+  */
++#define _GNU_SOURCE 1
+ #include "lispd_input.h"
+ #include "lispd_map_notify.h"
+--- a/lispd/lispd_pkt_lib.c
++++ b/lispd/lispd_pkt_lib.c
+@@ -28,6 +28,8 @@
+  *
+  */
++#define _GNU_SOURCE 1
++
+ #include "lispd_afi.h"
+ #include "lispd_pkt_lib.h"
+ #include "lispd_lib.h"