mariadb: ensure columnstore engine is disabled
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Thu, 4 Nov 2021 16:45:17 +0000 (13:45 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Thu, 4 Nov 2021 18:12:55 +0000 (15:12 -0300)
mariadb may detect boost libraries, if the latter has been built with
threads, date_time and chorno support, then it will enable the
columnstore engine, which fails to build.

Set PKG_RELEASE:=$(AUTORLEASE).

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
utils/mariadb/Makefile

index 6a14242f642806b174299df1bced6e6fa675631b..55fb191db06f401edf01f47beaae9553bc1c53f0 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mariadb
 PKG_VERSION:=10.6.4
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL := https://archive.mariadb.org/$(PKG_NAME)-$(PKG_VERSION)/source
@@ -36,6 +36,7 @@ MARIADB_SOCKET=/var/run/mysqld/mysqld.sock
 
 MARIADB_DISABLE_ENGINES := \
        cassandra \
+       columnstore \
        example \
        mroonga \
        oqgraph \