ovpn-dco: Avoid building against musl headers
authorSven Eckelmann <sven@narfation.org>
Sat, 27 Nov 2021 13:51:53 +0000 (14:51 +0100)
committerRosen Penev <rosenp@gmail.com>
Mon, 29 Nov 2021 09:44:11 +0000 (01:44 -0800)
The musl headers contain defines which are incompatible with kernel builds.
For example alltypes.h contain a __BIG_ENDIAN define. This will force
various kernel functions/macros to be build in a way which requires the
target system to be big endian. But if the target system is actually little
endian, these function will then not perform there intended tasks. The
actual (hard to debug) effects can vary between minor problems and fatal
errors.

This is port of the fix from OpenWrt's commit 9ac47ee46918 ("build: use
-nostdinc and -isystem in NOSTDINC_FLAGS for out-of-tree kernel modules")

Fixes: 17cd1793bbec ("ovpn-dco: Add package")
Signed-off-by: Sven Eckelmann <sven@narfation.org>
kernel/ovpn-dco/Makefile

index 2e94fe9fb7f725890da4d7b16c6ce79822e33983..ffd72cb56a81bfbf7aa4bb4ac8501445b71b42a9 100644 (file)
@@ -37,6 +37,7 @@ define KernelPackage/ovpn-dco/description
 endef
 
 NOSTDINC_FLAGS += \
+       $(KERNEL_NOSTDINC_FLAGS) \
        -I$(PKG_BUILD_DIR)/include \
        -include $(PKG_BUILD_DIR)/linux-compat.h