armsr: remove redundant phy-marvell-10g module
authorDaniel Golle <daniel@makrotopia.org>
Fri, 11 Aug 2023 13:16:08 +0000 (14:16 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 13 Aug 2023 15:30:14 +0000 (16:30 +0100)
the Marvell 10G PHY driver is no way specific to ARM SystemReady
systems, it frequently occurs on SFP+ copper modules and is useful on
many targets.

Hence it been added to package/kernel/linux/modules/netdevices and we
can remove the now redundant target-specific module.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit c524a76f4c09a4e3fa4572612d336b4ef7ff2fb8)

target/linux/armsr/modules.mk

index 86acc8c4c796ce20ec17fa296a0f9508906bac08..8b026093ee66f9b38398d6bf2d1a0676d8a82b86 100644 (file)
@@ -151,17 +151,6 @@ endef
 
 $(eval $(call KernelPackage,marvell-mdio))
 
-define KernelPackage/phy-marvell-10g
-  SUBMENU:=$(NETWORK_DEVICES_MENU)
-  TITLE:=Marvell Alaska 10G PHY driver
-  DEPENDS:=@(TARGET_armsr_armv8) +kmod-libphy
-  KCONFIG:=CONFIG_MARVELL_10G_PHY
-  FILES=$(LINUX_DIR)/drivers/net/phy/marvell10g.ko
-  AUTOLOAD=$(call AutoLoad,35,marvell10g)
-endef
-
-$(eval $(call KernelPackage,phy-marvell-10g))
-
 define KernelPackage/mvneta
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Marvell Armada 370/38x/XP/37xx network driver