ipq40xx: Select correct board-2.bin for EnGenius EMR3500
authorSven Eckelmann <sven@narfation.org>
Sat, 11 Sep 2021 06:33:30 +0000 (08:33 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sun, 19 Sep 2021 18:01:00 +0000 (20:01 +0200)
The board data file for the EnGenius EMR3500 is not part of the default
board-2.bin which is shipped by ath10k-board-qca4019. As result, the wrong
calibration information will be loaded into the wifi chip.

Fixes: 3f61e5e1b97e ("ipq40xx: add support for EnGenius EMR3500")
Signed-off-by: Sven Eckelmann <sven@narfation.org>
(cherry picked from commit 14bd392a1cd0b8e267e4402ae27b3c5a8f66b933)

target/linux/ipq40xx/image/generic.mk

index 6f88e3178a3e9442bfba1fc3f9310ddcc75b9e37..99881b70a59eddbac07714004208340de062a94e 100644 (file)
@@ -424,6 +424,7 @@ define Device/engenius_emr3500
        IMAGES += factory.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
        IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
+       DEVICE_PACKAGES := ipq-wifi-engenius_emr3500
 endef
 TARGET_DEVICES += engenius_emr3500