imagemagick: copy *-config files to staging dir
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Fri, 26 Feb 2021 14:58:40 +0000 (11:58 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Mon, 1 Mar 2021 01:30:08 +0000 (22:30 -0300)
We need to copy MagickWand-config, which handles pkg-config data, to the
staging dir, so that dependent packages can use it.  php7-pecl-imagick,
for example, may otherwise use an eventual host-installed file, causing
compilation to fail.  There's also a MagickCore-config file that does
the same thing for the MagickCore library, so a *-config wilcard is used
to handle all cases.

Since configure is called with --prefix=/usr, use $(SED) to change
definition of prefix and exec_prefix lines in *-config from /usr to
$(STAGING_DIR)/usr.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
multimedia/imagemagick/Makefile

index 48242513182d354e65f59f1c8aedb41448a7e3d1..6397be753764be30a62596e3d6803c2f968bf174 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=imagemagick
 PKG_VERSION:=7.0.9
 PKG_REVISION:=5
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_MAINTAINER:=Val Kulkov <val.kulkov@gmail.com>
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REVISION).tar.gz
@@ -126,6 +126,13 @@ define Build/InstallDev
        $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
                $(1)/usr/lib/pkgconfig/
+
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/*-config \
+               $(1)/usr/bin/
+       $(SED) 's|prefix=/usr|prefix=$(STAGING_DIR)/usr|' \
+               $(1)/usr/bin/*-config
 endef
 
 IMlibdir:=usr/lib/ImageMagick-$(PKG_VERSION)