CMake: bump the minimum required CMake version to 3.5
[project/netifd.git] / CMakeLists.txt
index bcb5133deda050155caf5f6c9a339a4a3db37aa5..a3eaf65e6c81ad605d9746a0433bd5fa19a43d53 100644 (file)
@@ -1,13 +1,16 @@
-cmake_minimum_required(VERSION 2.6)
+cmake_minimum_required(VERSION 3.5)
 
 PROJECT(netifd C)
 
-IF(NOT ${CMAKE_VERSION} LESS 3.0)
-  include(CheckCCompilerFlag)
-  check_c_compiler_flag(-Wimplicit-fallthrough HAS_IMPLICIT_FALLTHROUGH)
-ENDIF()
+include(CheckCCompilerFlag)
+check_c_compiler_flag(-Wimplicit-fallthrough HAS_IMPLICIT_FALLTHROUGH)
 
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-unknown-warning-option -Wno-format-truncation)
+ADD_DEFINITIONS(-Wall -Werror)
+IF(CMAKE_C_COMPILER_VERSION VERSION_GREATER 6)
+       add_definitions(-Wextra -Werror=implicit-function-declaration)
+       add_definitions(-Wformat -Werror=format-security -Werror=format-nonliteral)
+ENDIF()
+ADD_DEFINITIONS(-Os --std=gnu99 -Wmissing-declarations -Wno-unused-parameter -Wno-unused-but-set-parameter)
 
 IF(HAS_IMPLICIT_FALLTHROUGH)
   ADD_DEFINITIONS(-Wimplicit-fallthrough)
@@ -24,8 +27,18 @@ SET(SOURCES
        extdev.c bonding.c)
 
 
-SET(LIBS
-       ubox ubus uci json-c blobmsg_json)
+FIND_LIBRARY(uci NAMES uci)
+FIND_LIBRARY(ubox NAMES ubox)
+FIND_LIBRARY(ubus NAMES ubus)
+FIND_LIBRARY(json NAMES json-c json)
+FIND_LIBRARY(udebug NAMES udebug)
+FIND_LIBRARY(blobmsg_json NAMES blobmsg_json)
+
+SET(LIBS ${ubox} ${ubus} ${uci} ${json} ${blobmsg_json} ${udebug})
+
+FIND_PATH(ubox_include_dir libubox/usock.h)
+FIND_PATH(udebug_include_dir udebug.h)
+INCLUDE_DIRECTORIES(${ubox_include_dir})
 
 IF (NOT DEFINED LIBNL_LIBS)
        include(FindPkgConfig)
@@ -36,6 +49,13 @@ IF (NOT DEFINED LIBNL_LIBS)
        ENDIF()
 ENDIF()
 
+ADD_CUSTOM_COMMAND(
+       OUTPUT ethtool-modes.h
+       COMMAND ./make_ethtool_modes_h.sh ${CMAKE_C_COMPILER} > ./ethtool-modes.h
+       DEPENDS ./make_ethtool_modes_h.sh
+)
+ADD_CUSTOM_TARGET(ethtool-modes-h DEPENDS ethtool-modes.h)
+
 IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
        SET(SOURCES ${SOURCES} system-linux.c)
        SET(LIBS ${LIBS} ${LIBNL_LIBS})
@@ -59,3 +79,4 @@ TARGET_LINK_LIBRARIES(netifd ${LIBS})
 INSTALL(TARGETS netifd
        RUNTIME DESTINATION sbin
 )
+ADD_DEPENDENCIES(netifd ethtool-modes-h)