kernel: limit crypto-hw-talitos to the mpc85xx and layerscape
[openwrt/staging/ynezz.git] / package / kernel / linux / modules / crypto.mk
index aa578e1da01a240ae09843ef4ba8477c1f41cf95..35d840b2297b97e946412e7660c2b8d7dc704f1b 100644 (file)
@@ -420,7 +420,8 @@ $(eval $(call KernelPackage,crypto-hw-safexcel))
 
 define KernelPackage/crypto-hw-talitos
   TITLE:=Freescale integrated security engine (SEC) driver
-  DEPENDS:=+kmod-crypto-manager +kmod-crypto-hash +kmod-random-core +kmod-crypto-authenc +kmod-crypto-des
+  DEPENDS:=@(TARGET_mpc85xx||TARGET_layerscape) +kmod-crypto-manager \
+       +kmod-crypto-hash +kmod-random-core +kmod-crypto-authenc +kmod-crypto-des
   KCONFIG:= \
        CONFIG_CRYPTO_HW=y \
        CONFIG_CRYPTO_DEV_TALITOS \