ipq806x: convert each device to DSA implementation
[openwrt/staging/svanheule.git] / target / linux / ipq806x / image / chromium.mk
index ba989299760ea53fa2d774bd2e1792a431af6ed4..637f17a94acade184cb701ecbf18810079759112 100644 (file)
@@ -1,3 +1,8 @@
+define Device/dsa-migration
+  DEVICE_COMPAT_VERSION := 1.1
+  DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
+endef
+
 define Build/cros-gpt
        cp $@ $@.tmp 2>/dev/null || true
        ptgen -o $@.tmp -g \
@@ -47,6 +52,7 @@ endef
 
 define Device/asus_onhub
        $(call Device/OnhubImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := ASUS
        DEVICE_MODEL := OnHub SRT-AC1900
        DEVICE_DTS := $$(SOC)-asus-onhub
@@ -56,6 +62,7 @@ TARGET_DEVICES += asus_onhub
 
 define Device/tplink_onhub
        $(call Device/OnhubImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := TP-Link
        DEVICE_MODEL := OnHub AC1900 Cloud Router
        DEVICE_DTS := $$(SOC)-tplink-onhub