ipq40xx: chromium: Enable kmod-ramoops by default
[openwrt/staging/aparcar.git] / target / linux / ipq40xx / image / chromium.mk
index 2abd2df02ae4dd018ced778e2dc2c654a907fe0c..f6ac69ecf1433ab809ff82ab0dc33905f5c4375a 100644 (file)
@@ -30,7 +30,11 @@ define Device/google_wifi
        KERNEL_NAME := zImage
        IMAGES += factory.bin
        IMAGE/factory.bin := cros-gpt | append-kernel-part | append-rootfs
+       # Note: Chromium/Depthcharge-based bootloaders insert a reserved-memory
+       # ramoops node into the Device Tree automatically, so we can use
+       # kmod-ramoops.
        DEVICE_PACKAGES := partx-utils mkf2fs e2fsprogs \
-                          kmod-fs-ext4 kmod-fs-f2fs kmod-google-firmware
+                          kmod-fs-ext4 kmod-fs-f2fs kmod-google-firmware \
+                          kmod-ramoops
 endef
 TARGET_DEVICES += google_wifi