amlogic: Rework Makefiles
authorCarlo Caione <ccaione@baylibre.com>
Sat, 24 Aug 2019 17:37:46 +0000 (18:37 +0100)
committerCarlo Caione <ccaione@baylibre.com>
Thu, 5 Sep 2019 09:39:30 +0000 (10:39 +0100)
Now that every piece is in place, the makefiles can be refactored and
slightly beautified removing useless and redundant parts.

Signed-off-by: Carlo Caione <ccaione@baylibre.com>
Change-Id: If74e1909df52d475cf4b0dfed819d07d3a4c85b9

plat/amlogic/gxbb/platform.mk
plat/amlogic/gxl/platform.mk

index 27f3c423917ef1ba0cfe096ff57ba115276b0961..59c4f3d638c834ad30dacd117499682fe87065f5 100644 (file)
@@ -10,30 +10,29 @@ AML_PLAT            :=      plat/amlogic
 AML_PLAT_SOC           :=      ${AML_PLAT}/${PLAT}
 AML_PLAT_COMMON                :=      ${AML_PLAT}/common
 
-PLAT_INCLUDES          :=      -Iinclude/drivers/amlogic/              \
-                               -I${AML_PLAT_SOC}/include               \
+PLAT_INCLUDES          :=      -Iinclude/drivers/amlogic/                      \
+                               -I${AML_PLAT_SOC}/include                       \
                                -I${AML_PLAT_COMMON}/include
 
-GIC_SOURCES            :=      drivers/arm/gic/common/gic_common.c     \
-                               drivers/arm/gic/v2/gicv2_main.c         \
-                               drivers/arm/gic/v2/gicv2_helpers.c      \
+GIC_SOURCES            :=      drivers/arm/gic/common/gic_common.c             \
+                               drivers/arm/gic/v2/gicv2_main.c                 \
+                               drivers/arm/gic/v2/gicv2_helpers.c              \
                                plat/common/plat_gicv2.c
 
-PLAT_BL_COMMON_SOURCES :=      drivers/amlogic/console/aarch64/meson_console.S \
-                               ${AML_PLAT_SOC}/gxbb_common.c           \
-                               ${AML_PLAT_COMMON}/aml_topology.c       \
-                               ${XLAT_TABLES_LIB_SRCS}
-
-BL31_SOURCES           +=      lib/cpus/aarch64/cortex_a53.S           \
-                               plat/common/plat_psci_common.c          \
+BL31_SOURCES           +=      lib/cpus/aarch64/cortex_a53.S                   \
+                               plat/common/plat_psci_common.c                  \
+                               drivers/amlogic/console/aarch64/meson_console.S \
+                               ${AML_PLAT_SOC}/gxbb_bl31_setup.c               \
+                               ${AML_PLAT_SOC}/gxbb_pm.c                       \
+                               ${AML_PLAT_SOC}/gxbb_common.c                   \
                                ${AML_PLAT_COMMON}/aarch64/aml_helpers.S        \
-                               ${AML_PLAT_SOC}/gxbb_bl31_setup.c       \
-                               ${AML_PLAT_COMMON}/aml_efuse.c          \
-                               ${AML_PLAT_COMMON}/aml_mhu.c            \
-                               ${AML_PLAT_SOC}/gxbb_pm.c               \
-                               ${AML_PLAT_COMMON}/aml_scpi.c           \
-                               ${AML_PLAT_COMMON}/aml_sip_svc.c        \
-                               ${AML_PLAT_COMMON}/aml_thermal.c        \
+                               ${AML_PLAT_COMMON}/aml_efuse.c                  \
+                               ${AML_PLAT_COMMON}/aml_mhu.c                    \
+                               ${AML_PLAT_COMMON}/aml_scpi.c                   \
+                               ${AML_PLAT_COMMON}/aml_sip_svc.c                \
+                               ${AML_PLAT_COMMON}/aml_thermal.c                \
+                               ${AML_PLAT_COMMON}/aml_topology.c               \
+                               ${XLAT_TABLES_LIB_SRCS}                         \
                                ${GIC_SOURCES}
 
 # Tune compiler for Cortex-A53
index f4d3235507fed23c616f0a55f68614b7c4b47835..80c991ced362ffedf75e83b0af87cddc9f41727c 100644 (file)
@@ -13,31 +13,30 @@ AML_PLAT_COMMON             :=      ${AML_PLAT}/common
 DOIMAGEPATH            ?=      tools/amlogic
 DOIMAGETOOL            ?=      ${DOIMAGEPATH}/doimage
 
-PLAT_INCLUDES          :=      -Iinclude/drivers/amlogic/              \
-                               -I${AML_PLAT_SOC}/include               \
+PLAT_INCLUDES          :=      -Iinclude/drivers/amlogic/                      \
+                               -I${AML_PLAT_SOC}/include                       \
                                -I${AML_PLAT_COMMON}/include
 
-GIC_SOURCES            :=      drivers/arm/gic/common/gic_common.c     \
-                               drivers/arm/gic/v2/gicv2_main.c         \
-                               drivers/arm/gic/v2/gicv2_helpers.c      \
+GIC_SOURCES            :=      drivers/arm/gic/common/gic_common.c             \
+                               drivers/arm/gic/v2/gicv2_main.c                 \
+                               drivers/arm/gic/v2/gicv2_helpers.c              \
                                plat/common/plat_gicv2.c
 
-PLAT_BL_COMMON_SOURCES :=      drivers/amlogic/console/aarch64/meson_console.S \
-                               ${AML_PLAT_SOC}/gxl_common.c            \
-                               ${AML_PLAT_COMMON}/aml_topology.c       \
-                               ${XLAT_TABLES_LIB_SRCS}
-
-BL31_SOURCES           +=      lib/cpus/aarch64/cortex_a53.S           \
-                               plat/common/plat_psci_common.c          \
+BL31_SOURCES           +=      lib/cpus/aarch64/cortex_a53.S                   \
+                               plat/common/plat_psci_common.c                  \
+                               drivers/amlogic/console/aarch64/meson_console.S \
+                               ${AML_PLAT_SOC}/gxl_bl31_setup.c                \
+                               ${AML_PLAT_SOC}/gxl_pm.c                        \
+                               ${AML_PLAT_SOC}/gxl_common.c                    \
                                ${AML_PLAT_COMMON}/aarch64/aml_helpers.S        \
-                               ${AML_PLAT_SOC}/gxl_bl31_setup.c        \
-                               ${AML_PLAT_COMMON}/aml_efuse.c          \
-                               ${AML_PLAT_COMMON}/aml_mhu.c            \
-                               ${AML_PLAT_SOC}/gxl_pm.c                \
-                               ${AML_PLAT_COMMON}/aml_scpi.c           \
-                               ${AML_PLAT_COMMON}/aml_sip_svc.c        \
-                               ${AML_PLAT_COMMON}/aml_thermal.c        \
-                               drivers/amlogic/crypto/sha_dma.c        \
+                               ${AML_PLAT_COMMON}/aml_efuse.c                  \
+                               ${AML_PLAT_COMMON}/aml_mhu.c                    \
+                               ${AML_PLAT_COMMON}/aml_scpi.c                   \
+                               ${AML_PLAT_COMMON}/aml_sip_svc.c                \
+                               ${AML_PLAT_COMMON}/aml_thermal.c                \
+                               ${AML_PLAT_COMMON}/aml_topology.c               \
+                               drivers/amlogic/crypto/sha_dma.c                \
+                               ${XLAT_TABLES_LIB_SRCS}                         \
                                ${GIC_SOURCES}
 
 # Tune compiler for Cortex-A53