tcpreplay: fix compilation with Arch Linux
authorRosen Penev <rosenp@gmail.com>
Wed, 23 Dec 2020 02:55:23 +0000 (18:55 -0800)
committerRosen Penev <rosenp@gmail.com>
Fri, 10 Sep 2021 20:12:34 +0000 (13:12 -0700)
It tries to link to host libraries for some reason. Add autoreconf to
fix. Also remove redundant prefixes.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 87177eef7539d6cd092063dc0a1aa67726cff2a6)

net/tcpreplay/Makefile

index a8066ecef1482c5be2fb314ae10e738fa7413fb9..792e92e39392db69a8df160280ad8edd3adbbfe9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tcpreplay
 PKG_VERSION:=4.3.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/appneta/tcpreplay/releases/download/v$(PKG_VERSION)
@@ -19,7 +19,7 @@ PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=docs/LICENSE
 PKG_CPE_ID:=cpe:/a:appneta:tcpreplay
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -135,8 +135,6 @@ CONFIGURE_VARS += \
 CONFIGURE_ARGS += \
        --enable-force-pf \
        --enable-dynamic-link \
-       --prefix="$(PKG_INSTALL_DIR)/usr" \
-       --exec-prefix="$(PKG_INSTALL_DIR)/usr" \
        --with-libpcap="$(STAGING_DIR)/usr"
 
 define tcpreplayTemplate