AA: iptables: backport r36867 (#13653)
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 6 Jun 2013 14:05:23 +0000 (14:05 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 6 Jun 2013 14:05:23 +0000 (14:05 +0000)
SVN-Revision: 36869

package/iptables/Makefile

index 45a1c8766ff35b1f1e3aabd40284c4a4b337a759..e36a0935dc914aeb7c4f93f348451b1cca59e4fd 100644 (file)
@@ -387,6 +387,10 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/xtables.pc $(1)/usr/lib/pkgconfig/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libiptc.pc $(1)/usr/lib/pkgconfig/
+
+       # XXX: needed by firewall3
+       $(INSTALL_DIR) $(1)/usr/lib/iptables
+       $(CP) $(PKG_BUILD_DIR)/extensions/libext*.a $(1)/usr/lib/iptables/
 endef
 
 define Package/iptables/install