luci-app-https-dns-proxy: add OpenDNS servers 4311/head
authorStan Grishin <stangri@melmac.net>
Wed, 29 Jul 2020 09:41:27 +0000 (09:41 +0000)
committerStan Grishin <stangri@melmac.net>
Wed, 29 Jul 2020 09:41:27 +0000 (09:41 +0000)
Signed-off-by: Stan Grishin <stangri@melmac.net>
applications/luci-app-https-dns-proxy/Makefile
applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.doh.lua [new file with mode: 0644]
applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.familyshield.doh.lua [new file with mode: 0644]
applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot

index b18e019aaae83c286d6e944513d94b3c76ff2c09..097f93b641f26394bc6a4e4a94ba9356a14cff29 100644 (file)
@@ -10,7 +10,7 @@ LUCI_TITLE:=DNS Over HTTPS Proxy Web UI
 LUCI_DESCRIPTION:=Provides Web UI for DNS Over HTTPS Proxy
 LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full +https-dns-proxy
 LUCI_PKGARCH:=all
-PKG_RELEASE:=9
+PKG_RELEASE:=10
 
 include ../../luci.mk
 
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.doh.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.doh.lua
new file mode 100644 (file)
index 0000000..b3eff18
--- /dev/null
@@ -0,0 +1,8 @@
+return {
+       name = "OpenDNS",
+       label = _("OpenDNS"),
+       resolver_url = "https://doh.opendns.com/dns-query",
+       bootstrap_dns = "208.67.222.222,208.67.220.220",
+       help_link = "https://support.opendns.com/hc/en-us/articles/360038086532-Using-DNS-over-HTTPS-DoH-with-OpenDNS",
+       help_link_text = "OpenDNS"
+}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.familyshield.doh.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.familyshield.doh.lua
new file mode 100644 (file)
index 0000000..12cc89a
--- /dev/null
@@ -0,0 +1,8 @@
+return {
+       name = "OpenDNS-FamilyShield",
+       label = _("OpenDNS (Family Shield)"),
+       resolver_url = "https://doh.familyshield.opendns.com/dns-query",
+       bootstrap_dns = "208.67.222.123,208.67.220.123",
+       help_link = "https://support.opendns.com/hc/en-us/articles/360038086532-Using-DNS-over-HTTPS-DoH-with-OpenDNS",
+       help_link_text = "OpenDNS"
+}
index 0194ef08e1cb0835d8a1f2ac0a33035ed26f3621..7b680cd15ca71b0e47efd8dc11a40ba62588161f 100644 (file)
@@ -81,6 +81,10 @@ msgstr ""
 msgid "Google"
 msgstr ""
 
+#: applications/luci-app-https-dns-proxy/root/usr/share/rpcd/acl.d/luci-app-https-dns-proxy.json:3
+msgid "Grant UCI and file access for luci-app-https-dns-proxy"
+msgstr ""
+
 #: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:126
 msgid "Instances"
 msgstr ""
@@ -109,6 +113,14 @@ msgstr ""
 msgid "ODVR (nic.cz)"
 msgstr ""
 
+#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.doh.lua:3
+msgid "OpenDNS"
+msgstr ""
+
+#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.familyshield.doh.lua:3
+msgid "OpenDNS (Family Shield)"
+msgstr ""
+
 #: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:177
 msgid "Proxy server"
 msgstr ""