python packages cleanup, add some missing deps
authorFelix Fietkau <nbd@openwrt.org>
Sun, 10 Aug 2008 16:12:31 +0000 (16:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 10 Aug 2008 16:12:31 +0000 (16:12 +0000)
SVN-Revision: 12271

13 files changed:
lang/egenix-mx/Makefile
lang/gst-python/Makefile
lang/kid/Makefile
lang/logilab-astng/Makefile
lang/logilab-common/Makefile
lang/psycopg/Makefile
lang/pybluez/Makefile
lang/pyevent/Makefile
lang/pymysql/Makefile
lang/pypcap/Makefile
lang/pysqlite/Makefile
lang/twisted/Makefile
lang/yapsnmp/Makefile

index 7e5001b2a62fbfdc889f527b8a8090c915bc88a5..35bdcf09914b36f9503bb99e16bda8cb2a04cb2b 100644 (file)
@@ -21,9 +21,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-egenix-mx
   SUBMENU:=Python
@@ -40,6 +37,7 @@ define Package/python-egenix-mx/description
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                build --build-lib="foo", \
                BASECFLAGS="$(TARGET_CFLAGS)" \
index e2e626108309b094bfe09cf5c20419681e97096d..61af262589e9b28136fe3cff273ffba26ea4c651 100644 (file)
@@ -26,7 +26,7 @@ define Package/gst-python
   CATEGORY:=Languages
   TITLE:=python bindings for dbus
   URL:=http://gstreamer.freedesktop.org/
-  DEPENDS:=+gstreamer +gst-plugins-base @BROKEN
+  DEPENDS:=+gstreamer +gst-plugins-base +python-gtk @BROKEN
 endef
 
 define Package/gst-python/description
index 0e93eeeb3ed69addf9e6df6e8ae0287a32b33f58..ff15a5421fe38a1738dd8afb319e077543188874 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-kid
   SUBMENU:=Python
@@ -44,6 +41,7 @@ define PyPackage/python-kid/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
index 7d018e0eca526e2b117a5e49f73432ff5b9057cf..eec67a86fda96acb10c06e0b865f800c532cd204 100644 (file)
@@ -15,9 +15,6 @@ PKG_SOURCE_URL:=ftp://ftp.logilab.fr/pub/astng/
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/logilab-astng
   SUBMENU:=Python
@@ -33,6 +30,7 @@ define Package/logilab-astng/description
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
index 5e69a5840566528a9bf8cda96c09660378c0aff7..26c31ae953f06f2a99400351a5e9af609bf92025 100644 (file)
@@ -15,9 +15,6 @@ PKG_SOURCE_URL:=ftp://ftp.logilab.fr/pub/common/
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/logilab-common
   SUBMENU:=Python
@@ -33,6 +30,7 @@ define Package/logilab-common/description
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
index 288b754964f2e509ae3e3a588405e1f660e5ddad..f4060568f6f642833b80fbdbf752edd4753491cc 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-psycopg
   SUBMENU:=Python
@@ -45,6 +42,7 @@ CONFIGURE_ARGS += \
        --with-mxdatetime-includes="$(STAGING_DIR)$(PYTHON_PKG_DIR)/mx/DateTime/mxDateTime" \
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                OPT="$(TARGET_CFLAGS)"
 endef
index 3abfef03c01f4d74fa1764ccc06a716d8926f922..8eb645982b6f5e51a514c9769f153b7e6602df1d 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-bluez
   SUBMENU:=Python
@@ -41,7 +38,8 @@ CONFIGURE_ARGS += \
        --with-python="$(PYTHON)" \
 
 define Build/Compile
-       $(call Build/Compile/PyMod,., \
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
+       $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
 endef
index 01d93a4c26dec7ad16416ab12ddc38f9e5abf5ec..0b2403e32b5df877c6d129c4c4d4c4ae135b7629 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-event
   SUBMENU:=Python
@@ -38,7 +35,8 @@ define PyPackage/python-event/filespec
 endef
 
 define Build/Compile
-       $(call Build/Compile/PyMod,., \
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
+       $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
                LIBEVENT_HOME="$(STAGING_DIR)/usr/lib" \
        )
index c0b6701c6092ad36ad1ce0ab25d4e4812e4bb9c3..8b0486a8dafde77cc9c2cfaf02248fcb0ea45933 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-mysql
   SUBMENU:=Python
@@ -45,6 +42,7 @@ define PyPackage/python-mysql/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
index 23d6645e692fb5687a3128fc763433090a0dca1b..aa3c0e1975eacc6578029a732fbdfdd842c24430 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-pcap
   SUBMENU:=Python
@@ -38,6 +35,7 @@ define PyPackage/python-pcap/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
                PCAP_HOME="$(STAGING_DIR)/usr" \
index b1629fbf5b6d28e90d57b822d5dd59b382d30cb7..ee74d7fccce5b159a7b572b9a413553cf6078381 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-sqlite
  SUBMENU:=Python
@@ -44,6 +41,7 @@ define PyPackage/python-sqlite/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr", \
        )
index 03a557634a0141ea3742313ced64740cf0021e30..4acaac49e34ed2a4076963312dc9ada06d39a70e 100644 (file)
@@ -21,9 +21,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/twisted/default
   SUBMENU:=Python
@@ -218,6 +215,7 @@ define PyPackage/zope-interface/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                install --prefix="$(PKG_INSTALL_DIR)/usr" --no-compile, \
                TWISTED_SUBPROJECTS="$(TWISTED_SUBPROJECTS)" \
index ce597c1c1101edcdc2a4f3c523fd0e5e0aabebd5..e60d11dce893e7f36e7262c993b579e3657f5281 100644 (file)
@@ -22,9 +22,6 @@ PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/python-yapsnmp
   SUBMENU:=Python
@@ -58,6 +55,7 @@ CONFIGURE_VARS += \
        ac_cv_prog_SWIG="echo MISSING SWIG" \
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                INCLUDES="-I$(PYTHON_INC_DIR)" \
                SNMPINCDIR="$(STAGING_DIR)/usr/include/net-snmp/library" \