uspot: update to Git HEAD (2024-03-25)
authorThibaut VARÈNE <hacks@slashdirt.org>
Mon, 25 Mar 2024 10:33:51 +0000 (11:33 +0100)
committerTianling Shen <cnsztl@gmail.com>
Wed, 27 Mar 2024 09:30:57 +0000 (17:30 +0800)
56eebdad085e uspot: wrap spotfilter device under tip_mode
1a96d57e5fe0 uspot: client_enable() wrap spotfilter data in tip_mode
fe12f9a7abde uspot: clear ratelimit state on startup/shutdown
976badc4d0b6 update README
53b8cb88a94a Makefile: require minimum ucode version
ff6163190d5a uspot/portal: report client_enable() failure
8601d9199233 include sample radcli dictionaries
c670f6c4b48f update README
094f0df88150 uspot: work around ucode#191 missing in 23.05

Update the package Makefile to reflect the changes from the following
above-listed commit:

53b8cb88a94a Makefile: require minimum ucode version

Fixes: https://github.com/f00b4r0/uspot/issues/4
Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
net/uspot/Makefile

index 9207c77b9a4d3186c1feb45c40a428c22552a73c..b721ae7c1f635859056a9d19f288da85bea09913 100644 (file)
@@ -8,9 +8,9 @@ PKG_MAINTAINER:=Thibaut VARÈNE <hacks@slashdirt.org>
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/f00b4r0/uspot.git
-PKG_SOURCE_DATE:=2024-01-09
-PKG_SOURCE_VERSION:=c4b6f2f0bb1e9d2da4adc8cb3523cd7e440d7584
-PKG_MIRROR_HASH:=fa6be10e0479a9dc71b8c21e57b07aac09c8938e8e7120045816a5cd4b949343
+PKG_SOURCE_DATE:=2024-03-25
+PKG_SOURCE_VERSION:=094f0df88150ff2c351cfca4fabf76a7edcac79d
+PKG_MIRROR_HASH:=2ffc723e6560e76f53496b444568724d3c52a45ac143ca259096c3d20522de0f
 
 CMAKE_SOURCE_SUBDIR:=src
 
@@ -22,6 +22,7 @@ define Package/uspot
   SECTION:=net
   CATEGORY:=Network
   TITLE:=uspot hotspot daemon
+  EXTRA_DEPENDS:=ucode (>= 2023-11-07)
   DEPENDS:=+conntrack \
           +libblobmsg-json +liblucihttp-ucode +libradcli +libubox +libubus +libuci \
           +spotfilter \
@@ -63,6 +64,7 @@ define Package/uspotfilter
   TITLE:=uspot implementation of spotfilter
   PROVIDES:=spotfilter
   CONFLICTS:=spotfilter
+  EXTRA_DEPENDS:=ucode (>= 2023-11-07)
   DEPENDS:=+conntrack +nftables-json +ucode +ucode-mod-rtnl +ucode-mod-uloop
   PKGARCH:=all
 endef