php7: update to 7.2.14
authorMichael Heimpold <mhei@heimpold.de>
Fri, 11 Jan 2019 22:47:30 +0000 (23:47 +0100)
committerMichael Heimpold <mhei@heimpold.de>
Fri, 11 Jan 2019 22:51:47 +0000 (23:51 +0100)
While at, add --with-pic to configure arguments. This prevents the following
build errors spotted by the build bots for i386 targets:

-snip-
...
ext/openssl/.libs/openssl.o: direct GOT relocation R_386_GOT32X against
`X509_REQ_free' without base register can not be used when making a shared object
...
-snap-

This parameter seems to make no difference on other targets, nor
improve or make worse the package size.

Run tested for i386 in VirtualBox VM and on Duckbill for mxs platform.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lang/php7/Makefile

index 149941793ff819b822d529d667fe02e2c3a76ff5..a36dfbb1f2042a3d33b4b4067b0ca61655e14427 100644 (file)
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
-PKG_VERSION:=7.2.13
+PKG_VERSION:=7.2.14
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -16,7 +16,7 @@ PKG_LICENSE_FILES:=LICENSE
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www.php.net/distributions/
-PKG_HASH:=14b0429abdb46b65c843e5882c9a8c46b31dfbf279c747293b8ab950c2644a4b
+PKG_HASH:=ee3f1cc102b073578a3c53ba4420a76da3d9f0c981c02b1664ae741ca65af84f
 
 PKG_FIXUP:=libtool autoreconf
 PKG_BUILD_PARALLEL:=1
@@ -175,6 +175,7 @@ CONFIGURE_ARGS+= \
        --enable-fpm \
        --enable-shared \
        --disable-static \
+       --with-pic \
        --disable-rpath \
        --disable-debug \
        --disable-phpdbg \