wget: bump to 1.15. Fixes compilation in buildhost with new perl (bugs 15563 and...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 27 Apr 2014 17:50:59 +0000 (17:50 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 27 Apr 2014 17:50:59 +0000 (17:50 +0000)
Compiling wget 1.14 in buildhosts with new perl (& texinfo?) versions may fail.
I experienced this with Ubuntu 14.04 x64 (with perl 5.18).
Bugs about this:
https://dev.openwrt.org/ticket/15718
https://dev.openwrt.org/ticket/15563

The problem has been fixed upstream in wget:
http://git.savannah.gnu.org/cgit/wget.git/commit/?id=9e8d899a356d95be34737488bb8fd59d4c6b3dbd
​
http://git.savannah.gnu.org/cgit/wget.git/commit/doc?id=7f43748544f26008d0dd337704f02a6ed3200aaf

Both fixes are included in the already released wget 1.15.
Compiling that succeeds without any need to patch wget source.

I have compiled ax71xx for WNDR3700 and it compiled ok and works.

Signed-off-by: hannu.nyman@iki.fi
SVN-Revision: 40574

net/wget/Makefile

index 297ece043891a19484ea100674a4297e1db5d7aa..bea4523bee0720df3dcc5affa9ad9bfff2618bf6 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wget
-PKG_VERSION:=1.14
+PKG_VERSION:=1.15
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=316f6f59292c9098ad81fd54f658c579
+PKG_MD5SUM:=7a279d5ac5594919124d5526e7143e28
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)