Merge pull request #1325 from michpappas/tf-issues#568_qemu_add_ENABLE_STACK_PROTECTOR
authorDimitris Papastamos <dimitris.papastamos@arm.com>
Thu, 29 Mar 2018 10:27:36 +0000 (11:27 +0100)
committerGitHub <noreply@github.com>
Thu, 29 Mar 2018 10:27:36 +0000 (11:27 +0100)
qemu: Add support for stack canary protection

1  2 
plat/qemu/platform.mk

index 017807b000904650479a2dd226e1704277ce924b,e11f5042971109cc839b6df2c46d4c170eb3b905..379ab3dcae4dd2a533ea3749c0a7857182fff3a8
@@@ -169,13 -168,11 +169,17 @@@ $(eval $(call TOOL_ADD_IMG,bl32_extra2,
  endif
  
  SEPARATE_CODE_AND_RODATA := 1
+ ENABLE_STACK_PROTECTOR         := 0
+ ifneq ($(ENABLE_STACK_PROTECTOR), 0)
+       PLAT_BL_COMMON_SOURCES += plat/qemu/qemu_stack_protector.c
+ endif
  
 +# Use MULTI_CONSOLE_API by default only on AArch64
 +# as it is not yet supported on AArch32
 +ifeq ($(ARCH),aarch64)
 +MULTI_CONSOLE_API     := 1
 +endif
 +
  # Disable the PSCI platform compatibility layer
  ENABLE_PLAT_COMPAT    :=      0