attendedsysupgrade-common: update ASU CA pubkey
authorPaul Spooren <mail@aparcar.org>
Fri, 28 Oct 2022 11:17:13 +0000 (13:17 +0200)
committerPaul Spooren <mail@aparcar.org>
Sat, 29 Oct 2022 08:00:27 +0000 (10:00 +0200)
The old key was overwritten during a machine migration and the current
worker key is no longer valid. To create new valid worker certificates
this commit adds a new CA pubkey.

To update running OpenWrt devices via a client one needs to force
install it or upgrade to the latest version of
`attendedsysupgrade-common` - I'm sorry for the inconvenience.

This change is only related to the `usign` pubkey and `ucert`
certificate which is used to sign all created images on the server.

While at it, use INSTALL_DATA instead of INSTALL_BIN.

Signed-off-by: Paul Spooren <mail@aparcar.org>
utils/attendedsysupgrade-common/Makefile
utils/attendedsysupgrade-common/files/86241a707a30cb7f [deleted file]
utils/attendedsysupgrade-common/files/8a11255d14aef6c8 [new file with mode: 0644]

index 4408b81d4ca0a3ccaad0bb90c72dd349ca9a27eb..766e8b0b9dc4ed664a7b29e75027abdb4ce0fadd 100644 (file)
@@ -49,10 +49,10 @@ endef
 
 define Package/attendedsysupgrade-common/install
        $(INSTALL_DIR) $(1)/etc/uci-defaults/
-       $(INSTALL_BIN) ./files/attendedsysupgrade.defaults $(1)/etc/uci-defaults/attendedsysupgrade
+       $(INSTALL_DATA) ./files/attendedsysupgrade.defaults $(1)/etc/uci-defaults/attendedsysupgrade
 
        $(INSTALL_DIR) $(1)/etc/opkg/keys/
-       $(INSTALL_BIN) ./files/86241a707a30cb7f $(1)/etc/opkg/keys/86241a707a30cb7f
+       $(INSTALL_DATA) ./files/8a11255d14aef6c8 $(1)/etc/opkg/keys/8a11255d14aef6c8
 endef
 
 $(eval $(call BuildPackage,attendedsysupgrade-common))
diff --git a/utils/attendedsysupgrade-common/files/86241a707a30cb7f b/utils/attendedsysupgrade-common/files/86241a707a30cb7f
deleted file mode 100644 (file)
index 8007327..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-untrusted comment: ASU CA pubkey
-RWSGJBpwejDLf4OApA5SOavh0GBlBFY9FhqxnivUQHpi0/t0QRI98LPW
diff --git a/utils/attendedsysupgrade-common/files/8a11255d14aef6c8 b/utils/attendedsysupgrade-common/files/8a11255d14aef6c8
new file mode 100644 (file)
index 0000000..ef20600
--- /dev/null
@@ -0,0 +1,2 @@
+untrusted comment: ASU CA pubkey 2022
+RWSKESVdFK72yB0Y5q0ckpqqXU+51UbFYYMPRrOTMdNjvLkU1tjJTSiU