libunistring: remove package
authorTianling Shen <cnsztl@immortalwrt.org>
Mon, 15 May 2023 14:58:42 +0000 (22:58 +0800)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 15 May 2023 17:36:37 +0000 (19:36 +0200)
It's merged into core now [1], so remove it here.

1. https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=d3c3b79c1e46c49cfa5de9df6a740d5fcda46471

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
libs/libunistring/Makefile [deleted file]

diff --git a/libs/libunistring/Makefile b/libs/libunistring/Makefile
deleted file mode 100644 (file)
index 595b530..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-#
-# Copyright (C) 2006-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libunistring
-PKG_VERSION:=1.1
-PKG_RELEASE:=1
-PKG_HASH:=827c1eb9cb6e7c738b171745dac0888aa58c5924df2e59239318383de0729b98
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=@GNU/libunistring
-PKG_BUILD_PARALLEL:=1
-PKG_INSTALL:=1
-
-PKG_MAINTAINER:=Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
-PKG_LICENSE:=GPL-3.0
-PKG_LICENSE_FILES:=COPYING
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libunistring
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=libunistring
-  URL:=http://www.gnu.org/software/libunistring/
-endef
-
-define Package/libunistring/description
-  This library provides functions for manipulating Unicode strings and for manipulating C strings according to the Unicode standard.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-CONFIGURE_ARGS += \
-       --enable-shared \
-       --enable-static \
-       --without-libiconv-prefix \
-       --without-libpth-prefix
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/include/unistring
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/unistring/*.h $(1)/usr/include/unistring/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libunistring.{a,so*} $(1)/usr/lib/
-endef
-
-define Package/libunistring/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libunistring.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libunistring))