Workaround for Neoverse N1 erratum 1275112
authorlauwal01 <lauren.wehrmeister@arm.com>
Mon, 24 Jun 2019 16:49:01 +0000 (11:49 -0500)
committerlauwal01 <lauren.wehrmeister@arm.com>
Tue, 2 Jul 2019 14:17:19 +0000 (09:17 -0500)
Neoverse N1 erratum 1275112 is a Cat B erratum [1],
present in older revisions of the Neoverse N1 processor core.
The workaround is to set a bit in the implementation defined
CPUACTLR_EL1 system register, which delays instruction fetch after
branch misprediction.

[1] http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.pjdoc-466751330-10325/index.html

Change-Id: If7fe55fe92e656fa6aea12327ab297f2e6119833
Signed-off-by: Lauren Wehrmeister <lauren.wehrmeister@arm.com>
docs/design/cpu-specific-build-macros.rst
lib/cpus/aarch64/neoverse_n1.S
lib/cpus/cpu-ops.mk

index 91032c4de756648deefc536aab97a1f4da17aca1..d3fe89d622ef80020419a2125c18321016150158 100644 (file)
@@ -252,6 +252,9 @@ For Neoverse N1, the following errata build flags are defined :
 -  ``ERRATA_N1_1262888``: This applies errata 1262888 workaround to Neoverse-N1
    CPU. This needs to be enabled only for revision <= r3p0 of the CPU.
 
+-  ``ERRATA_N1_1275112``: This applies errata 1275112 workaround to Neoverse-N1
+   CPU. This needs to be enabled only for revision <= r3p0 of the CPU.
+
 -  ``ERRATA_N1_1315703``: This applies errata 1315703 workaround to Neoverse-N1
    CPU. This needs to be enabled only for revision <= r3p0 of the CPU.
 
index d5f2247381d9c1caac2b727dd31921fa4c2394ce..cffdf9eb6f768306fe85fb1bb114167026e89714 100644 (file)
@@ -292,6 +292,33 @@ func check_errata_1262888
        b       cpu_rev_var_ls
 endfunc check_errata_1262888
 
+/* --------------------------------------------------
+ * Errata Workaround for Neoverse N1 Errata #1275112
+ * This applies to revision <=r3p0 of Neoverse N1.
+ * Inputs:
+ * x0: variant[4:7] and revision[0:3] of current cpu.
+ * Shall clobber: x0-x17
+ * --------------------------------------------------
+ */
+func errata_n1_1275112_wa
+       /* Compare x0 against revision r3p0 */
+       mov     x17, x30
+       bl      check_errata_1275112
+       cbz     x0, 1f
+       mrs     x1, NEOVERSE_N1_CPUACTLR_EL1
+       orr     x1, x1, NEOVERSE_N1_CPUACTLR_EL1_BIT_13
+       msr     NEOVERSE_N1_CPUACTLR_EL1, x1
+       isb
+1:
+       ret     x17
+endfunc errata_n1_1275112_wa
+
+func check_errata_1275112
+       /* Applies to <=r3p0 */
+       mov     x1, #0x30
+       b       cpu_rev_var_ls
+endfunc check_errata_1275112
+
 /* --------------------------------------------------
  * Errata Workaround for Neoverse N1 Erratum 1315703.
  * This applies to revision <= r3p0 of Neoverse N1.
@@ -380,6 +407,11 @@ func neoverse_n1_reset_func
        bl      errata_n1_1262888_wa
 #endif
 
+#if ERRATA_N1_1275112
+       mov     x0, x18
+       bl      errata_n1_1275112_wa
+#endif
+
 #if ERRATA_N1_1315703
        mov     x0, x18
        bl      errata_n1_1315703_wa
@@ -450,6 +482,7 @@ func neoverse_n1_errata_report
        report_errata ERRATA_N1_1257314, neoverse_n1, 1257314
        report_errata ERRATA_N1_1262606, neoverse_n1, 1262606
        report_errata ERRATA_N1_1262888, neoverse_n1, 1262888
+       report_errata ERRATA_N1_1275112, neoverse_n1, 1275112
        report_errata ERRATA_N1_1315703, neoverse_n1, 1315703
        report_errata ERRATA_DSU_936184, neoverse_n1, dsu_936184
 
index 2f13696d6f0d26edff875ac0653dda044622a46b..260402351a72c2b2d95cacf3a4290833a78bc250 100644 (file)
@@ -270,6 +270,10 @@ ERRATA_N1_1262606  ?=0
 # only to revision <= r3p0 of the Neoverse N1 cpu.
 ERRATA_N1_1262888      ?=0
 
+# Flag to apply erratum 1275112 workaround during reset. This erratum applies
+# only to revision <= r3p0 of the Neoverse N1 cpu.
+ERRATA_N1_1275112      ?=0
+
 # Flag to apply erratum 1315703 workaround during reset. This erratum applies
 # to revisions before r3p1 of the Neoverse N1 cpu.
 ERRATA_N1_1315703      ?=1
@@ -495,6 +499,10 @@ $(eval $(call add_define,ERRATA_N1_1262606))
 $(eval $(call assert_boolean,ERRATA_N1_1262888))
 $(eval $(call add_define,ERRATA_N1_1262888))
 
+# Process ERRATA_N1_1275112 flag
+$(eval $(call assert_boolean,ERRATA_N1_1275112))
+$(eval $(call add_define,ERRATA_N1_1275112))
+
 # Process ERRATA_N1_1315703 flag
 $(eval $(call assert_boolean,ERRATA_N1_1315703))
 $(eval $(call add_define,ERRATA_N1_1315703))