kernel: bump 4.14 to 4.14.167
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 24 Jan 2020 10:21:08 +0000 (11:21 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 24 Jan 2020 12:18:01 +0000 (13:18 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch

index 362986192a18834311db31588a28131211fdc832..fc3eba145a768a4736812c15e8319ed76e65f9fe 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .211
-LINUX_VERSION-4.14 = .166
+LINUX_VERSION-4.14 = .167
 
 LINUX_KERNEL_HASH-4.9.211 = 2597608d5d974cfdc015eaf6a4197b36f19d722b8a309b57e741fb02e311b1be
-LINUX_KERNEL_HASH-4.14.166 = 8bb2bf811a2092933a2386a4e679cd0c88de979c10fbb463d8142add4e577c00
+LINUX_KERNEL_HASH-4.14.167 = 2bb78fc7a902faf4f5dad47fdbc2f4bf3df3cf9b41f408e7260f36656659fe43
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index f70cfef7624737d83c392e5a0d1cce9ff4c6d2df..c09a5e47f81894adf31d6d8b759b72660e54730b 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1975,7 +1975,8 @@ static const struct usb_device_id option
+@@ -1981,7 +1981,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },