asterisk-chan-sccp: remove BUILD_USER BUILD_DATE 223/head
authorAlexander Couzens <lynxis@fe80.eu>
Wed, 6 Dec 2017 01:48:03 +0000 (02:48 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Wed, 6 Dec 2017 20:27:24 +0000 (21:27 +0100)
Build timestamps prevent reproducible builds [0].

[0] https://reproducible-builds.org/docs/timestamps/

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
net/asterisk-chan-sccp/Makefile
net/asterisk-chan-sccp/patches/100-reproducible-builds.patch [new file with mode: 0644]

index 77c776e5a06522c79432c6c7170792477b63bf33..7180fb165e4632adab7fe907a5c87fb990d7a11f 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=chan-sccp
 PKG_VERSION:=v4.3.0-20171123
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/chan-sccp/chan-sccp.git
diff --git a/net/asterisk-chan-sccp/patches/100-reproducible-builds.patch b/net/asterisk-chan-sccp/patches/100-reproducible-builds.patch
new file mode 100644 (file)
index 0000000..f10a750
--- /dev/null
@@ -0,0 +1,13 @@
+Index: chan-sccp-v4.3.0-20171123/src/chan_sccp.c
+===================================================================
+--- chan-sccp-v4.3.0-20171123.orig/src/chan_sccp.c
++++ chan-sccp-v4.3.0-20171123/src/chan_sccp.c
+@@ -186,7 +186,7 @@ boolean_t sccp_postPBX_load(void)
+ #else
+       snprintf(SCCP_REVISIONSTR, sizeof(SCCP_REVISIONSTR), "%s", SCCP_REVISION);
+ #endif
+-      snprintf(SCCP_VERSIONSTR, sizeof(SCCP_VERSIONSTR), "Skinny Client Control Protocol (SCCP). Release: %s %s - %s (built by '%s' on '%s')\n", SCCP_VERSION, SCCP_BRANCH, SCCP_REVISIONSTR, BUILD_USER, BUILD_DATE);
++      snprintf(SCCP_VERSIONSTR, sizeof(SCCP_VERSIONSTR), "Skinny Client Control Protocol (SCCP). Release: %s %s - %s\n", SCCP_VERSION, SCCP_BRANCH, SCCP_REVISIONSTR);
+       GLOB(module_running) = TRUE;
+       pbx_rwlock_unlock(&GLOB(lock));