sunxi: move fpu feature flag into the subtargets
[openwrt/staging/stintel.git] / target / linux / sunxi / Makefile
index dbe85bd9ea94b4f5e5b51b2b5cc4e0dc5c62cca8..511c02772eb4c587a5ab7bab2b107ccc366474fd 100644 (file)
@@ -1,29 +1,31 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2013-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2013-2016 OpenWrt.org
 
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=sunxi
-BOARDNAME:=Allwinner A1x/A20/A3x
-FEATURES:=fpu usb ext4 display rtc
-CPU_TYPE:=cortex-a8
-CPU_SUBTYPE:=vfpv3
-MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
+BOARDNAME:=Allwinner ARM SoCs
+FEATURES:=usb ext4 display rootfs-part rtc squashfs
+SUBTARGETS:=cortexa8 cortexa7 cortexa53
+
+KERNEL_PATCHVER:=6.1
 
-KERNEL_PATCHVER:=3.18
 KERNELNAME:=zImage dtbs
-DEFAULT_PACKAGES += uboot-envtools uboot-sunxi kmod-eeprom-sunxi kmod-wdt-sunxi
 
 # A10: Cortex-A8
 # A13: Cortex-A8
 # A20: dual Cortex-A7
 # A31: quad Cortex-A7
+# A80: octa Cortex-A15/A7
+# H3: quad Cortex-A7
+# R40: quad Cortex-A7
+# A64/H5/H6/H616: quad Cortex-A53
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))