sunxi: move fpu feature flag into the subtargets
[openwrt/staging/stintel.git] / target / linux / sunxi / Makefile
index 982eecbcbd3920e16665181b595bf86e87ca21fc..511c02772eb4c587a5ab7bab2b107ccc366474fd 100644 (file)
@@ -1,20 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2013-2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=sunxi
-BOARDNAME:=Allwinner A1x/A20/A3x
-FEATURES:=fpu usb ext4 display rtc squashfs
+BOARDNAME:=Allwinner ARM SoCs
+FEATURES:=usb ext4 display rootfs-part rtc squashfs
 SUBTARGETS:=cortexa8 cortexa7 cortexa53
-MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
-KERNEL_PATCHVER:=4.9
+KERNEL_PATCHVER:=6.1
+
 KERNELNAME:=zImage dtbs
 
 # A10: Cortex-A8
@@ -23,6 +20,8 @@ KERNELNAME:=zImage dtbs
 # A31: quad Cortex-A7
 # A80: octa Cortex-A15/A7
 # H3: quad Cortex-A7
+# R40: quad Cortex-A7
+# A64/H5/H6/H616: quad Cortex-A53
 
 include $(INCLUDE_DIR)/target.mk