jh71x0: refresh patches and configs once again
[openwrt/staging/wigyori.git] / target / linux / jh71x0 / patches-6.1 / 0009-reset-starfive-Factor-out-common-JH71X0-reset-code.patch
index 9dd6f573509eda8362aad6a94836ac2dfec2b0e6..e651bca1012fa359c7d32d11fc69adb7f3f4ce13 100644 (file)
@@ -1,7 +1,7 @@
-From 1d09aa1b9fa2b5040d996f7fc5547c8fbaccc20f Mon Sep 17 00:00:00 2001
+From a8051a7daa45056f469686286886968bc62b94df Mon Sep 17 00:00:00 2001
 From: Emil Renner Berthing <kernel@esmil.dk>
 Date: Sat, 1 Apr 2023 19:19:21 +0800
-Subject: [PATCH 009/129] reset: starfive: Factor out common JH71X0 reset code
+Subject: [PATCH 009/122] reset: starfive: Factor out common JH71X0 reset code
 
 The StarFive JH7100 SoC has additional reset controllers for audio and
 video, but the registers follow the same structure. On the JH7110 the
@@ -26,7 +26,7 @@ Signed-off-by: Conor Dooley <conor.dooley@microchip.com>
  create mode 100644 drivers/reset/starfive/reset-starfive-jh71x0.h
 
 diff --git a/drivers/reset/starfive/Kconfig b/drivers/reset/starfive/Kconfig
-index abbf0c52d..1927a5a3b 100644
+index abbf0c52d03e..1927a5a3b53a 100644
 --- a/drivers/reset/starfive/Kconfig
 +++ b/drivers/reset/starfive/Kconfig
 @@ -1,8 +1,12 @@
@@ -43,7 +43,7 @@ index abbf0c52d..1927a5a3b 100644
        help
          This enables the reset controller driver for the StarFive JH7100 SoC.
 diff --git a/drivers/reset/starfive/Makefile b/drivers/reset/starfive/Makefile
-index 670d04942..f6aa12466 100644
+index 670d049423f5..f6aa12466fad 100644
 --- a/drivers/reset/starfive/Makefile
 +++ b/drivers/reset/starfive/Makefile
 @@ -1,2 +1,4 @@
@@ -52,7 +52,7 @@ index 670d04942..f6aa12466 100644
 +
  obj-$(CONFIG_RESET_STARFIVE_JH7100)           += reset-starfive-jh7100.o
 diff --git a/drivers/reset/starfive/reset-starfive-jh7100.c b/drivers/reset/starfive/reset-starfive-jh7100.c
-index fc44b2fb3..5a68327c1 100644
+index fc44b2fb3e03..5a68327c1f6a 100644
 --- a/drivers/reset/starfive/reset-starfive-jh7100.c
 +++ b/drivers/reset/starfive/reset-starfive-jh7100.c
 @@ -5,158 +5,10 @@
@@ -217,7 +217,7 @@ index fc44b2fb3..5a68327c1 100644
        { .compatible = "starfive,jh7100-reset" },
 diff --git a/drivers/reset/starfive/reset-starfive-jh71x0.c b/drivers/reset/starfive/reset-starfive-jh71x0.c
 new file mode 100644
-index 000000000..114a13c4b
+index 000000000000..114a13c4b8a6
 --- /dev/null
 +++ b/drivers/reset/starfive/reset-starfive-jh71x0.c
 @@ -0,0 +1,162 @@
@@ -385,7 +385,7 @@ index 000000000..114a13c4b
 +EXPORT_SYMBOL_GPL(jh7100_reset_probe);
 diff --git a/drivers/reset/starfive/reset-starfive-jh71x0.h b/drivers/reset/starfive/reset-starfive-jh71x0.h
 new file mode 100644
-index 000000000..318d7a0e0
+index 000000000000..318d7a0e096a
 --- /dev/null
 +++ b/drivers/reset/starfive/reset-starfive-jh71x0.h
 @@ -0,0 +1,11 @@
@@ -401,5 +401,5 @@ index 000000000..318d7a0e0
 +
 +#endif /* __RESET_STARFIVE_JH71X0_H */
 -- 
-2.25.1
+2.20.1