kernel: bump 4.14 to 4.14.134
[openwrt/staging/lynxis.git] / target / linux / generic / pending-4.19 / 100-MIPS-fix-build-on-non-linux-hosts.patch
index 7204a7176c286074b393b9b2b095838da02438ea..5d34df4283c88a51a4369396e18a2aa53e56123f 100644 (file)
@@ -31,11 +31,9 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
  arch/mips/boot/compressed/calc_vmlinuz_load_addr.c | 2 +-
  2 files changed, 3 insertions(+), 1 deletion(-)
 
-diff --git a/arch/mips/boot/compressed/Makefile b/arch/mips/boot/compressed/Makefile
-index 3c453a1f1ff1..172801ed35b8 100644
 --- a/arch/mips/boot/compressed/Makefile
 +++ b/arch/mips/boot/compressed/Makefile
-@@ -78,6 +78,8 @@ OBJCOPYFLAGS_piggy.o := --add-section=.image=$(obj)/vmlinux.bin.z \
+@@ -78,6 +78,8 @@ OBJCOPYFLAGS_piggy.o := --add-section=.i
  $(obj)/piggy.o: $(obj)/dummy.o $(obj)/vmlinux.bin.z FORCE
        $(call if_changed,objcopy)
  
@@ -44,11 +42,9 @@ index 3c453a1f1ff1..172801ed35b8 100644
  # Calculate the load address of the compressed kernel image
  hostprogs-y := calc_vmlinuz_load_addr
  
-diff --git a/arch/mips/boot/compressed/calc_vmlinuz_load_addr.c b/arch/mips/boot/compressed/calc_vmlinuz_load_addr.c
-index 240f1d12df75..080b926d2623 100644
 --- a/arch/mips/boot/compressed/calc_vmlinuz_load_addr.c
 +++ b/arch/mips/boot/compressed/calc_vmlinuz_load_addr.c
-@@ -9,7 +9,7 @@
+@@ -13,7 +13,7 @@
  #include <stdint.h>
  #include <stdio.h>
  #include <stdlib.h>
@@ -57,6 +53,3 @@ index 240f1d12df75..080b926d2623 100644
  
  int main(int argc, char *argv[])
  {
--- 
-2.20.1 (Apple Git-117)
-