build: replace uses of OpenWrt with $(VERSION_DIST)
[openwrt/staging/kaloz.git] / include / image-commands.mk
index bcc1256df838ac3c27015dc24c7cdd031bd19514..adef8f2759536495519e3f13ff4e2abfa33aa6cb 100644 (file)
@@ -7,7 +7,7 @@ define Build/uImage
        mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-               -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION))' -d $@ $@.new
+               -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' -d $@ $@.new
        mv $@.new $@
 endef
 
@@ -60,7 +60,7 @@ endef
 
 define Build/netgear-dni
        $(STAGING_DIR_HOST)/bin/mkdniimg \
-               -B $(NETGEAR_BOARD_ID) -v OpenWrt.$(REVISION) \
+               -B $(NETGEAR_BOARD_ID) -v $(VERSION_DIST).$(REVISION) \
                $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
                -r "$(1)" \
                -i $@ -o $@.new
@@ -83,7 +83,7 @@ define Build/append-uImage-fakeroot-hdr
        rm -f $@.fakeroot
        $(STAGING_DIR_HOST)/bin/mkimage \
                -A $(LINUX_KARCH) -O linux -T filesystem -C none \
-               -n '$(call toupper,$(LINUX_KARCH)) OpenWrt fakeroot' \
+               -n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) fakeroot' \
                -s \
                $@.fakeroot
        cat $@.fakeroot >> $@