Merge changes I0283fc2e,Ib476d024,Iada05f7c into integration
[project/bcm63xx/atf.git] / Makefile
index ecff944f749c7e6ad715185e853cf47fa6eb6913..32918c385e571f284a9080ab2e15e2dc98d68b0d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -695,6 +695,10 @@ $(eval $(call assert_numeric,ARM_ARCH_MAJOR))
 $(eval $(call assert_numeric,ARM_ARCH_MINOR))
 $(eval $(call assert_numeric,BRANCH_PROTECTION))
 
+ifdef KEY_SIZE
+        $(eval $(call assert_numeric,KEY_SIZE))
+endif
+
 ifeq ($(filter $(SANITIZE_UB), on off trap),)
         $(error "Invalid value for SANITIZE_UB: can be one of on, off, trap")
 endif