add udebug support
[project/netifd.git] / CMakeLists.txt
index ca5d944d96ffc05854b579055c74d25cb2a701d4..8e86bd4ce598738daa1848895f3c9d3d38e4259c 100644 (file)
@@ -7,7 +7,12 @@ IF(NOT ${CMAKE_VERSION} LESS 3.0)
   check_c_compiler_flag(-Wimplicit-fallthrough HAS_IMPLICIT_FALLTHROUGH)
 ENDIF()
 
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-unknown-warning-option -Wno-format-truncation)
+ADD_DEFINITIONS(-Wall -Werror)
+IF(CMAKE_C_COMPILER_VERSION VERSION_GREATER 6)
+       add_definitions(-Wextra -Werror=implicit-function-declaration)
+       add_definitions(-Wformat -Werror=format-security -Werror=format-nonliteral)
+ENDIF()
+ADD_DEFINITIONS(-Os --std=gnu99 -Wmissing-declarations -Wno-unused-parameter -Wno-unused-but-set-parameter)
 
 IF(HAS_IMPLICIT_FALLTHROUGH)
   ADD_DEFINITIONS(-Wimplicit-fallthrough)
@@ -21,11 +26,21 @@ SET(SOURCES
        iprule.c proto.c proto-static.c proto-shell.c
        config.c device.c bridge.c veth.c vlan.c alias.c
        macvlan.c ubus.c vlandev.c wireless.c
-       extdev.c)
+       extdev.c bonding.c)
+
+
+FIND_LIBRARY(uci NAMES uci)
+FIND_LIBRARY(ubox NAMES ubox)
+FIND_LIBRARY(ubus NAMES ubus)
+FIND_LIBRARY(json NAMES json-c json)
+FIND_LIBRARY(udebug NAMES udebug)
+FIND_LIBRARY(blobmsg_json NAMES blobmsg_json)
 
+SET(LIBS ${ubox} ${ubus} ${uci} ${json} ${blobmsg_json} ${udebug})
 
-SET(LIBS
-       ubox ubus uci json-c blobmsg_json)
+FIND_PATH(ubox_include_dir libubox/usock.h)
+FIND_PATH(udebug_include_dir udebug.h)
+INCLUDE_DIRECTORIES(${ubox_include_dir})
 
 IF (NOT DEFINED LIBNL_LIBS)
        include(FindPkgConfig)
@@ -36,6 +51,13 @@ IF (NOT DEFINED LIBNL_LIBS)
        ENDIF()
 ENDIF()
 
+ADD_CUSTOM_COMMAND(
+       OUTPUT ethtool-modes.h
+       COMMAND ./make_ethtool_modes_h.sh ${CMAKE_C_COMPILER} > ./ethtool-modes.h
+       DEPENDS ./make_ethtool_modes_h.sh
+)
+ADD_CUSTOM_TARGET(ethtool-modes-h DEPENDS ethtool-modes.h)
+
 IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
        SET(SOURCES ${SOURCES} system-linux.c)
        SET(LIBS ${LIBS} ${LIBNL_LIBS})
@@ -59,3 +81,4 @@ TARGET_LINK_LIBRARIES(netifd ${LIBS})
 INSTALL(TARGETS netifd
        RUNTIME DESTINATION sbin
 )
+ADD_DEPENDENCIES(netifd ethtool-modes-h)