modules: block: add libraid module
authorZoltan HERPAI <wigyori@uid0.hu>
Tue, 24 Oct 2023 16:40:24 +0000 (18:40 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Tue, 28 Nov 2023 22:28:47 +0000 (23:28 +0100)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/kernel/linux/modules/block.mk

index 5e6eefa76a94916ae8ef9c842bb361e6885eaa81..7389a928375a1f0b76830837402d851e3a9a9440 100644 (file)
@@ -443,6 +443,23 @@ endef
 $(eval $(call KernelPackage,libsas,1))
 
 
+define KernelPackage/libraid
+  SUBMENU:=$(BLOCK_MENU)
+  DEPENDS:=@TARGET_x86
+  TITLE:=RAID Transport class
+  KCONFIG:=CONFIG_RAID_ATTRS
+  FILES:= \
+       $(LINUX_DIR)/drivers/scsi/raid_class.ko
+  AUTOLOAD:=$(call AutoLoad,29,raid_class,1)
+endef
+
+define KernelPackage/libraid/description
+ RAID Transport Attributes support
+endef
+
+$(eval $(call KernelPackage,libraid,1))
+
+
 define KernelPackage/loop
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Loopback device support