mtd-utils: nand-tuils: build and package 'nandbiterrs'
authorDaniel Golle <daniel@makrotopia.org>
Wed, 8 May 2024 21:05:00 +0000 (22:05 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 8 May 2024 21:26:02 +0000 (22:26 +0100)
The 'nandbiterrs' tool is useful to find out of bit error correction of
NAND is working as expected by deliberately introducing bit errors and
telling up to which number they can be corrected.

Enable build of the testing tools and package the 'nandbiterrs' tool as
part of the nand-utils package.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/utils/mtd-utils/Makefile

index fd1cb75e51e48a061578456f6daae99cbef1cd49..c0ea0abbcb43de25d878c2221e4b0b87e53b05c0 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtd-utils
 PKG_VERSION:=2.1.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://infraroot.at/pub/mtd/
@@ -59,7 +59,7 @@ endef
 MAKE_FLAGS += LDLIBS+="$(LIBGCC_S)"
 
 CONFIGURE_ARGS += \
-       --disable-tests \
+       --enable-tests \
        --without-crypto \
        --without-xattr \
        --without-zstd \
@@ -76,7 +76,8 @@ endef
 define Package/nand-utils/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) \
-       $(PKG_INSTALL_DIR)/usr/sbin/{flash_erase,nanddump,nandwrite,nandtest,mtdinfo} $(1)/usr/sbin/
+       $(PKG_INSTALL_DIR)/usr/sbin/{flash_erase,nanddump,nandwrite,nandtest,mtdinfo} \
+       $(PKG_INSTALL_DIR)/usr/lib/mtd-utils/nandbiterrs $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ubi-utils))