kernel: bump 5.10 to 5.10.214
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 29 Mar 2024 16:34:32 +0000 (17:34 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 30 Mar 2024 11:09:05 +0000 (12:09 +0100)
Removed because similar version is upstream:
x86/patches-5.10/020-x86-Fix-compile-problem.patch
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.10.y&id=cc6ddd6fa93eb59ac6f63158a6466e45ad0ca94c

Manually adapted the following patch:
mediatek/patches-5.10/100-dts-update-mt7622-rfb1.patch

Add new configuration symbols for tegra target.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
23 files changed:
include/kernel-5.10
target/linux/at91/patches-5.10/247-clk-use-clk_core_get_rate_recalc-in-clk_rate_get.patch
target/linux/bcm27xx/patches-5.10/950-0408-drm-atomic-Pass-the-full-state-to-CRTC-atomic-enable.patch
target/linux/bcm27xx/patches-5.10/950-0410-drm-atomic-Pass-the-full-state-to-CRTC-atomic-begin-.patch
target/linux/bcm27xx/patches-5.10/950-0537-clk-Introduce-a-clock-request-API.patch
target/linux/bcm27xx/patches-5.10/950-0572-clk-requests-Ignore-if-the-pointer-is-null.patch
target/linux/bcm27xx/patches-5.10/950-0581-clk-requests-Dereference-the-request-pointer-after-t.patch
target/linux/bcm27xx/patches-5.10/950-0596-clk-Always-clamp-the-rounded-rate.patch
target/linux/bcm27xx/patches-5.10/950-0689-drm-automatic-legacy-gamma-support.patch
target/linux/generic/config-5.10
target/linux/mediatek/patches-5.10/100-dts-update-mt7622-rfb1.patch
target/linux/mediatek/patches-5.10/112-dts-fix-bpi64-lan-names.patch
target/linux/mediatek/patches-5.10/114-dts-bpi64-disable-rtc.patch
target/linux/mediatek/patches-5.10/115-dts-bpi64-add-snand-support.patch
target/linux/mediatek/patches-5.10/131-dts-mt7622-add-snand-support.patch
target/linux/mediatek/patches-5.10/140-dts-fix-wmac-support-for-mt7622-rfb1.patch
target/linux/mediatek/patches-5.10/180-dts-mt7622-bpi-r64-add-mt7531-irq.patch
target/linux/mediatek/patches-5.10/331-mt7622-rfb1-enable-bmt.patch
target/linux/mediatek/patches-5.10/602-arm64-dts-mediatek-Split-PCIe-node-for-MT2712-MT7622.patch
target/linux/mediatek/patches-5.10/900-dts-mt7622-bpi-r64-aliases-for-dtoverlay.patch
target/linux/mediatek/patches-5.10/910-dts-mt7622-bpi-r64-wifi-eeprom.patch
target/linux/octeontx/patches-5.10/0004-PCI-add-quirk-for-Gateworks-PLX-PEX860x-switch-with-.patch
target/linux/x86/patches-5.10/020-x86-Fix-compile-problem.patch [deleted file]

index ee8bf19a0b027e563ff2889a5c70a33649821465..a6abd1e14e9badb94f73aea106a55a065f4131f2 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.10 = .213
-LINUX_KERNEL_HASH-5.10.213 = 84cf30223239ec3333a5f7b2a7fba2042bba70d1582a139f7543956af871ad80
+LINUX_VERSION-5.10 = .214
+LINUX_KERNEL_HASH-5.10.214 = 40f014d53e81f204f6d2a364aae4201ae07970dd1b70dc602d7c66c1a140f558
index 436fa1836245827ea683b11c7927f132674031d1..c88945ebced28bf96733bf495feec92da540d864 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Stephen Boyd <sboyd@kernel.org>
 
 --- a/drivers/clk/clk.c
 +++ b/drivers/clk/clk.c
-@@ -3116,7 +3116,10 @@ static int clk_rate_get(void *data, u64
+@@ -3119,7 +3119,10 @@ static int clk_rate_get(void *data, u64
  {
        struct clk_core *core = data;
  
index 6a6d565968be27d5abb81695a7a9190dc41c9c92..e033a10dd945165d7b3d433d014dffdf7f4dc381 100644 (file)
@@ -567,7 +567,7 @@ Link: https://patchwork.freedesktop.org/patch/msgid/845aa10ef171fc0ea060495efef1
        unsigned int var;
 --- a/drivers/gpu/drm/mediatek/mtk_drm_crtc.c
 +++ b/drivers/gpu/drm/mediatek/mtk_drm_crtc.c
-@@ -520,7 +520,7 @@ void mtk_drm_crtc_async_update(struct dr
+@@ -522,7 +522,7 @@ void mtk_drm_crtc_async_update(struct dr
  }
  
  static void mtk_drm_crtc_atomic_enable(struct drm_crtc *crtc,
@@ -576,7 +576,7 @@ Link: https://patchwork.freedesktop.org/patch/msgid/845aa10ef171fc0ea060495efef1
  {
        struct mtk_drm_crtc *mtk_crtc = to_mtk_crtc(crtc);
        struct mtk_ddp_comp *comp = mtk_crtc->ddp_comp[0];
-@@ -545,7 +545,7 @@ static void mtk_drm_crtc_atomic_enable(s
+@@ -547,7 +547,7 @@ static void mtk_drm_crtc_atomic_enable(s
  }
  
  static void mtk_drm_crtc_atomic_disable(struct drm_crtc *crtc,
index 72b8abb20a685678120cc0d15cb238f3b7c04ced..888179c610ac3ec59a3b34550065a495a9a03360 100644 (file)
@@ -574,7 +574,7 @@ Link: https://patchwork.freedesktop.org/patch/msgid/20201028123222.1732139-2-max
                if (drm_crtc_vblank_get(crtc) == 0)
 --- a/drivers/gpu/drm/mediatek/mtk_drm_crtc.c
 +++ b/drivers/gpu/drm/mediatek/mtk_drm_crtc.c
-@@ -578,29 +578,29 @@ static void mtk_drm_crtc_atomic_disable(
+@@ -580,29 +580,29 @@ static void mtk_drm_crtc_atomic_disable(
  }
  
  static void mtk_drm_crtc_atomic_begin(struct drm_crtc *crtc,
index 9e07f72b497d5f6b51bb9b5284a685aa974ed216..bfbc7627103bab2b02dea88f3c93a7378783cc85 100644 (file)
@@ -75,7 +75,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
  /***           runtime pm          ***/
  static int clk_pm_runtime_get(struct clk_core *core)
  {
-@@ -1441,10 +1449,14 @@ unsigned long clk_hw_round_rate(struct c
+@@ -1444,10 +1452,14 @@ unsigned long clk_hw_round_rate(struct c
  {
        int ret;
        struct clk_rate_request req;
@@ -90,7 +90,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
        ret = clk_core_round_rate_nolock(hw->core, &req);
        if (ret)
                return 0;
-@@ -1465,6 +1477,7 @@ EXPORT_SYMBOL_GPL(clk_hw_round_rate);
+@@ -1468,6 +1480,7 @@ EXPORT_SYMBOL_GPL(clk_hw_round_rate);
  long clk_round_rate(struct clk *clk, unsigned long rate)
  {
        struct clk_rate_request req;
@@ -98,7 +98,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
        int ret;
  
        if (!clk)
-@@ -1478,6 +1491,9 @@ long clk_round_rate(struct clk *clk, uns
+@@ -1481,6 +1494,9 @@ long clk_round_rate(struct clk *clk, uns
        clk_core_get_boundaries(clk->core, &req.min_rate, &req.max_rate);
        req.rate = rate;
  
@@ -108,7 +108,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
        ret = clk_core_round_rate_nolock(clk->core, &req);
  
        if (clk->exclusive_count)
-@@ -1945,6 +1961,7 @@ static struct clk_core *clk_calc_new_rat
+@@ -1948,6 +1964,7 @@ static struct clk_core *clk_calc_new_rat
        unsigned long new_rate;
        unsigned long min_rate;
        unsigned long max_rate;
@@ -116,7 +116,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
        int p_index = 0;
        long ret;
  
-@@ -1959,6 +1976,9 @@ static struct clk_core *clk_calc_new_rat
+@@ -1962,6 +1979,9 @@ static struct clk_core *clk_calc_new_rat
  
        clk_core_get_boundaries(core, &min_rate, &max_rate);
  
@@ -126,7 +126,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
        /* find the closest rate and parent clk/rate */
        if (clk_core_can_round(core)) {
                struct clk_rate_request req;
-@@ -2163,6 +2183,7 @@ static unsigned long clk_core_req_round_
+@@ -2166,6 +2186,7 @@ static unsigned long clk_core_req_round_
  {
        int ret, cnt;
        struct clk_rate_request req;
@@ -134,7 +134,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
  
        lockdep_assert_held(&prepare_lock);
  
-@@ -2177,6 +2198,9 @@ static unsigned long clk_core_req_round_
+@@ -2180,6 +2201,9 @@ static unsigned long clk_core_req_round_
        clk_core_get_boundaries(core, &req.min_rate, &req.max_rate);
        req.rate = req_rate;
  
@@ -144,7 +144,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
        ret = clk_core_round_rate_nolock(core, &req);
  
        /* restore the protection */
-@@ -2270,6 +2294,9 @@ int clk_set_rate(struct clk *clk, unsign
+@@ -2273,6 +2297,9 @@ int clk_set_rate(struct clk *clk, unsign
  
        ret = clk_core_set_rate_nolock(clk->core, rate);
  
@@ -154,7 +154,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
        if (clk->exclusive_count)
                clk_core_rate_protect(clk->core);
  
-@@ -2436,6 +2463,99 @@ int clk_set_max_rate(struct clk *clk, un
+@@ -2439,6 +2466,99 @@ int clk_set_max_rate(struct clk *clk, un
  EXPORT_SYMBOL_GPL(clk_set_max_rate);
  
  /**
@@ -254,7 +254,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
   * clk_get_parent - return the parent of a clk
   * @clk: the clk whose parent gets returned
   *
-@@ -3888,6 +4008,7 @@ __clk_register(struct device *dev, struc
+@@ -3891,6 +4011,7 @@ __clk_register(struct device *dev, struc
                goto fail_parents;
  
        INIT_HLIST_HEAD(&core->clks);
index 2b70e3ccdaba58eef87ad4b69d6ac92d6638427f..92b9bf8cdf6e79e3e1de7cbcdbdc0718a8fa810a 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
 
 --- a/drivers/clk/clk.c
 +++ b/drivers/clk/clk.c
-@@ -2532,6 +2532,9 @@ void clk_request_done(struct clk_request
+@@ -2535,6 +2535,9 @@ void clk_request_done(struct clk_request
  {
        struct clk_core *core = req->clk->core;
  
index 4b81be57c34c2fa2d0073651373255d5d55b1e14..b7a910a718d4988ec07d2d4e4393666ece049b3b 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
 
 --- a/drivers/clk/clk.c
 +++ b/drivers/clk/clk.c
-@@ -2530,10 +2530,11 @@ EXPORT_SYMBOL_GPL(clk_request_start);
+@@ -2533,10 +2533,11 @@ EXPORT_SYMBOL_GPL(clk_request_start);
   */
  void clk_request_done(struct clk_request *req)
  {
index 2a9778401ff1ada06473b68d808120d6146a3ce8..ef0b3729cdb8366cab07a28959000684804be97d 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Maxime Ripard <maxime@cerno.tech>
 
 --- a/drivers/clk/clk.c
 +++ b/drivers/clk/clk.c
-@@ -1344,6 +1344,8 @@ static int clk_core_determine_round_nolo
+@@ -1347,6 +1347,8 @@ static int clk_core_determine_round_nolo
        if (!core)
                return 0;
  
index a25fb8b72cd684d34e15322ea757d29d3ac297fe..6a9e1a6ce3f4d561b670382b86a579a22f3bf87e 100644 (file)
@@ -357,7 +357,7 @@ Link: https://patchwork.freedesktop.org/patch/msgid/20201211114237.213288-2-tomi
  static const struct drm_plane_helper_funcs ingenic_drm_plane_helper_funcs = {
 --- a/drivers/gpu/drm/mediatek/mtk_drm_crtc.c
 +++ b/drivers/gpu/drm/mediatek/mtk_drm_crtc.c
-@@ -622,7 +622,6 @@ static const struct drm_crtc_funcs mtk_c
+@@ -624,7 +624,6 @@ static const struct drm_crtc_funcs mtk_c
        .reset                  = mtk_drm_crtc_reset,
        .atomic_duplicate_state = mtk_drm_crtc_duplicate_state,
        .atomic_destroy_state   = mtk_drm_crtc_destroy_state,
index c9a49cd1e04ca106cc86be4d2389ffe4a9529c8d..bc9fbbeaecb01a73e9bd84b2f7e1b9a9b249e864 100644 (file)
@@ -6098,6 +6098,8 @@ CONFIG_TCP_CONG_CUBIC=y
 # CONFIG_TCS3414 is not set
 # CONFIG_TCS3472 is not set
 # CONFIG_TEE is not set
+# CONFIG_TEGRA210_ADMA is not set
+# CONFIG_TEGRA_ACONNECT is not set
 # CONFIG_TEGRA_AHB is not set
 # CONFIG_TEGRA_HOST1X is not set
 # CONFIG_TEHUTI is not set
index 95baa0019d203b0c9014290130cb3befd7eabd3f..6a66bb7c5a2116ece799640b850fc190399937ab 100644 (file)
        memory@40000000 {
 -              reg = <0 0x40000000 0 0x20000000>;
 +              reg = <0 0x40000000 0 0x40000000>;
+               device_type = "memory";
        };
  
-       reg_1p8v: regulator-1p8v {
-@@ -132,22 +130,22 @@
+@@ -133,22 +131,22 @@
  
                                port@0 {
                                        reg = <0>;
@@ -73,7 +73,7 @@
                                };
  
                                port@4 {
-@@ -236,15 +234,28 @@
+@@ -237,15 +235,28 @@
  
  &pcie {
        pinctrl-names = "default";
        /* eMMC is shared pin with parallel NAND */
        emmc_pins_default: emmc-pins-default {
                mux {
-@@ -511,11 +522,11 @@
+@@ -512,11 +523,11 @@
  };
  
  &sata {
index 6ce85efde9815ecf67b713f58238773ef390530f..e88913c309fe30f74a295d3585c9fd7ace75ec40 100644 (file)
@@ -8,7 +8,7 @@
        };
  
        chosen {
-@@ -160,22 +161,22 @@
+@@ -161,22 +162,22 @@
  
                                port@1 {
                                        reg = <1>;
index 261579bf376b35ba282ded68b130c40dc43ecebe..ea112f7979ef0e301480a9cd8d51c9ecac4d37a2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64.dts
 +++ b/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64.dts
-@@ -559,12 +559,16 @@
+@@ -560,12 +560,16 @@
        status = "okay";
  };
  
index 39d81bd5d56ac4da66591bce4fde24b6f1c0dc0a..f66cdb7dc2c9d25de76124c5bb4baebfb25d1cc6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64.dts
 +++ b/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64.dts
-@@ -259,14 +259,32 @@
+@@ -260,14 +260,32 @@
        status = "disabled";
  };
  
index b337c9edcb6c7a640674fcb6f03bc1d327fae1cd..a9433c378e7cb14f07ad8b28611788da8db331db 100644 (file)
@@ -23,7 +23,7 @@
                             "mediatek,mt8173-nor";
 --- a/arch/arm64/boot/dts/mediatek/mt7622-rfb1.dts
 +++ b/arch/arm64/boot/dts/mediatek/mt7622-rfb1.dts
-@@ -529,6 +529,55 @@
+@@ -530,6 +530,55 @@
        status = "disabled";
  };
  
index e1e43ce75d69c085ffd344c883ca93101226c26e..90a20393d98e1b445b215b70dc00893002851dda 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm64/boot/dts/mediatek/mt7622-rfb1.dts
 +++ b/arch/arm64/boot/dts/mediatek/mt7622-rfb1.dts
-@@ -561,7 +561,7 @@
+@@ -562,7 +562,7 @@
                        reg = <0x140000 0x0080000>;
                };
  
@@ -9,7 +9,7 @@
                        label = "Factory";
                        reg = <0x1c0000 0x0100000>;
                };
-@@ -619,5 +619,6 @@
+@@ -620,5 +620,6 @@
  };
  
  &wmac {
index 80ceb490d4e43d00a2f45ba9238544b1988fad15..fabee390c720f8a35450ab783471c277cd639292 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64.dts
 +++ b/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64.dts
-@@ -160,6 +160,10 @@
+@@ -161,6 +161,10 @@
                switch@0 {
                        compatible = "mediatek,mt7531";
                        reg = <0>;
index a79bd8fcdc0e53fe4f2af7b54130dc2736edd422..6b68ed47dd59e2b38d9c2a69cebf25da4ea6d3c7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm64/boot/dts/mediatek/mt7622-rfb1.dts
 +++ b/arch/arm64/boot/dts/mediatek/mt7622-rfb1.dts
-@@ -535,6 +535,8 @@
+@@ -536,6 +536,8 @@
        pinctrl-0 = <&serial_nand_pins>;
        status = "okay";
  
index c7d5d4e691f577ea70482909fab0ef63e93046d8..7b6a9da45bf1cc1157c2ad4d3fcfd42a89b2a425 100644 (file)
@@ -253,7 +253,7 @@ Signed-off-by: chuanjia.liu <Chuanjia.Liu@mediatek.com>
                                #interrupt-cells = <1>;
 --- a/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64.dts
 +++ b/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64.dts
-@@ -292,18 +292,16 @@
+@@ -293,18 +293,16 @@
        };
  };
  
@@ -389,7 +389,7 @@ Signed-off-by: chuanjia.liu <Chuanjia.Liu@mediatek.com>
                                        <0 0 0 2 &pcie_intc1 1>,
 --- a/arch/arm64/boot/dts/mediatek/mt7622-rfb1.dts
 +++ b/arch/arm64/boot/dts/mediatek/mt7622-rfb1.dts
-@@ -232,18 +232,16 @@
+@@ -233,18 +233,16 @@
        };
  };
  
index 987513eb4546f7817a5a636ed1497bcd1299cd91..239265b9d2ddaf5208533393d78a56cf8f30a342 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64.dts
 +++ b/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64.dts
-@@ -308,7 +308,7 @@
+@@ -309,7 +309,7 @@
        /* Attention: GPIO 90 is used to switch between PCIe@1,0 and
         * SATA functions. i.e. output-high: PCIe, output-low: SATA
         */
index 21fb98c19e8dc50e35e62a6029e4f7f1815ae41b..ad344ece8be52991bc22ac6f46e19e8098309101 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64.dts
 +++ b/arch/arm64/boot/dts/mediatek/mt7622-bananapi-bpi-r64.dts
-@@ -632,5 +632,28 @@
+@@ -633,5 +633,28 @@
  };
  
  &wmac {
index 05eaa9aedfe7e8e31bc32a8640eb1ae43e5a12cc..3fffb38246c018facb710b2f29bab6d0889b2337 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
  #include <linux/platform_data/x86/apple.h>
  #include <linux/pm_runtime.h>
  #include <linux/suspend.h>
-@@ -5858,3 +5859,34 @@ static void nvidia_ion_ahci_fixup(struct
+@@ -5859,3 +5860,34 @@ static void nvidia_ion_ahci_fixup(struct
        pdev->dev_flags |= PCI_DEV_FLAGS_HAS_MSI_MASKING;
  }
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_NVIDIA, 0x0ab8, nvidia_ion_ahci_fixup);
diff --git a/target/linux/x86/patches-5.10/020-x86-Fix-compile-problem.patch b/target/linux/x86/patches-5.10/020-x86-Fix-compile-problem.patch
deleted file mode 100644 (file)
index ad33085..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
-From: Hauke Mehrtens <hauke@hauke-m.de>
-Date: Sun, 3 Mar 2024 19:57:11 +0100
-Subject: x86: Fix compile problem
-
-This fixes the following compile problem:
-  CC      arch/x86/kernel/paravirt.o
-arch/x86/kernel/paravirt.c: In function 'paravirt_patch_call':
-arch/x86/kernel/paravirt.c:65:9: error: implicit declaration of function '__text_gen_insn' [-Werror=implicit-function-declaration]
-   65 |         __text_gen_insn(insn_buff, CALL_INSN_OPCODE,
-      |         ^~~~~~~~~~~~~~~
-arch/x86/kernel/paravirt.c:65:36: error: 'CALL_INSN_OPCODE' undeclared (first use in this function)
-   65 |         __text_gen_insn(insn_buff, CALL_INSN_OPCODE,
-      |                                    ^~~~~~~~~~~~~~~~
-arch/x86/kernel/paravirt.c:65:36: note: each undeclared identifier is reported only once for each function it appears in
-arch/x86/kernel/paravirt.c:66:47: error: 'CALL_INSN_SIZE' undeclared (first use in this function)
-   66 |                         (void *)addr, target, CALL_INSN_SIZE);
-      |                                               ^~~~~~~~~~~~~~
-arch/x86/kernel/paravirt.c:68:1: error: control reaches end of non-void function [-Werror=return-type]
-   68 | }
-      | ^
-cc1: some warnings being treated as errors
-make[7]: *** [scripts/Makefile.build:286: arch/x86/kernel/paravirt.o] Error 1
-
-Fixes: b253061d4b86 ("x86/ibt,paravirt: Use text_gen_insn() for paravirt_patch()")
-Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
----
- arch/x86/kernel/paravirt.c | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/arch/x86/kernel/paravirt.c
-+++ b/arch/x86/kernel/paravirt.c
-@@ -14,6 +14,7 @@
- #include <linux/highmem.h>
- #include <linux/kprobes.h>
- #include <linux/pgtable.h>
-+#include <linux/static_call.h>
- #include <asm/bug.h>
- #include <asm/paravirt.h>