make clean should remove the BUILD_DIR
authorFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 19:56:41 +0000 (19:56 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 19:56:41 +0000 (19:56 +0000)
SVN-Revision: 2258

openwrt/Makefile

index d478227523d633749219e26b68318d23f25e7fe4..1702dd801a0616a3df8a175d69246e4e0c19373b 100644 (file)
@@ -101,10 +101,10 @@ image_clean:
 target_clean: image_clean
        rm -rf $(BUILD_DIR)/linux-*/root
 
-clean: target_clean
+clean: dirclean
        @$(MAKE) -C $(CONFIG) clean
 
-dirclean: clean
+dirclean: target_clean
        rm -rf $(BUILD_DIR)
 
 distclean: clean