packages/wide-dhcpv6: rename uci config files
authorNicolas Thill <nico@openwrt.org>
Thu, 17 Nov 2011 11:48:52 +0000 (11:48 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 17 Nov 2011 11:48:52 +0000 (11:48 +0000)
SVN-Revision: 29222

ipv6/wide-dhcpv6/Makefile
ipv6/wide-dhcpv6/files/dhcp6c.conf [deleted file]
ipv6/wide-dhcpv6/files/dhcp6c.config [new file with mode: 0644]
ipv6/wide-dhcpv6/files/dhcp6s.conf [deleted file]
ipv6/wide-dhcpv6/files/dhcp6s.config [new file with mode: 0644]

index 5971312fc91b5d964c0ec8d0177623bc5336d333..bdb74cc03d807b3c2021438a699a51e298113c2c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wide-dhcpv6
 PKG_VERSION:=20080615
-PKG_RELEASE:=8
+PKG_RELEASE:=9
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -100,11 +100,11 @@ define Package/wide-dhcpv6-client/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/dhcp6c $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_CONF) ./files/dhcp6c.conf $(1)/etc/config/dhcp6c
+       $(INSTALL_CONF) ./files/dhcp6c.config $(1)/etc/config/dhcp6c
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dhcp6c.init $(1)/etc/init.d/dhcp6c
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_DATA) ./files/dhcp6c.hotplug $(1)/etc/hotplug.d/iface/40-dhcp6c       
+       $(INSTALL_DATA) ./files/dhcp6c.hotplug $(1)/etc/hotplug.d/iface/40-dhcp6c
        $(INSTALL_DIR) $(1)/etc/hotplug.d/dhcp6c
        $(INSTALL_DATA) ./files/dhcp6c-dnsmasq.hotplug $(1)/etc/hotplug.d/dhcp6c/10-dnsmasq
        $(INSTALL_DATA) ./files/dhcp6c-radvd.hotplug $(1)/etc/hotplug.d/dhcp6c/20-radvd
@@ -122,11 +122,11 @@ define Package/wide-dhcpv6-server/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/dhcp6s.conf.sample $(1)/etc
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_CONF) ./files/dhcp6s.conf $(1)/etc/config/dhcp6s
+       $(INSTALL_CONF) ./files/dhcp6s.config $(1)/etc/config/dhcp6s
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dhcp6s.init $(1)/etc/init.d/dhcp6s
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_DATA) ./files/dhcp6s.hotplug $(1)/etc/hotplug.d/iface/50-dhcp6s       
+       $(INSTALL_DATA) ./files/dhcp6s.hotplug $(1)/etc/hotplug.d/iface/50-dhcp6s
 endef
 
 define Package/wide-dhcpv6-relay/install
diff --git a/ipv6/wide-dhcpv6/files/dhcp6c.conf b/ipv6/wide-dhcpv6/files/dhcp6c.conf
deleted file mode 100644 (file)
index 04a3ca9..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-config 'dhcp6c' 'basic'
-       option 'enabled' '0'                            # 1 = enabled; 0 = disabled
-       option 'interface' 'wan'                        # This is the interface the DHCPv6 client will run on
-       option 'dns' 'dnsmasq'                          # Which DNS server you run (only dnsmasq currently supported)
-       option 'debug' '0'                              # 1 = enable debugging; 0 = disable debugging
-       
-       # Send options (1 = send; 0 = do not send)
-       option 'pd' '1'                                 # Prefix Delegation
-       option 'na' '0'                                 # Non-Temporary Address
-       option 'rapid_commit' '1'                       # Rapid Commit
-       
-       # Request options (1 = request; 0 = do not request)
-       option 'domain_name_servers' '1'
-       option 'domain_name' '0'
-       option 'ntp_servers' '0'
-       option 'sip_server_address' '0'
-       option 'sip_server_domain_name' '0'
-       option 'nis_server_address' '0'
-       option 'nis_domain_name' '0'
-       option 'nisp_server_address' '0'
-       option 'nisp_domain_name' '0'
-       option 'bcmcs_server_address' '0'
-       option 'bcmcs_server_domain_name' '0'
-       
-       # Override the used DUID, by default it is derived from the interface MAC
-       # The given value must be uppercase and globally unique!
-       #option 'duid' '00:03:00:06:D8:5D:4C:A5:03:F2'
-
-       # Script to run when a reply is received
-       option 'script' '/usr/bin/dhcp6c-state'
-
-# Define one or more interfaces on which prefixes should be assigned
-config 'interface' 'loopback'
-       option 'enabled' '1'                            # 1 = enabled; 0 = disabled
-       option 'sla_id' '0'                             # Site level aggregator identifier specified in decimal (subnet)
-       option 'sla_len' '4'                            # Site level aggregator length (64 - size of prefix being delegated)
-                                                       # e.g. /60 from ISP -> 64 - 60 = 4
-
-config 'interface' 'lan'
-       option 'enabled' '1'
-       option 'sla_id' '1'
-       option 'sla_len' '4'
diff --git a/ipv6/wide-dhcpv6/files/dhcp6c.config b/ipv6/wide-dhcpv6/files/dhcp6c.config
new file mode 100644 (file)
index 0000000..04a3ca9
--- /dev/null
@@ -0,0 +1,42 @@
+config 'dhcp6c' 'basic'
+       option 'enabled' '0'                            # 1 = enabled; 0 = disabled
+       option 'interface' 'wan'                        # This is the interface the DHCPv6 client will run on
+       option 'dns' 'dnsmasq'                          # Which DNS server you run (only dnsmasq currently supported)
+       option 'debug' '0'                              # 1 = enable debugging; 0 = disable debugging
+       
+       # Send options (1 = send; 0 = do not send)
+       option 'pd' '1'                                 # Prefix Delegation
+       option 'na' '0'                                 # Non-Temporary Address
+       option 'rapid_commit' '1'                       # Rapid Commit
+       
+       # Request options (1 = request; 0 = do not request)
+       option 'domain_name_servers' '1'
+       option 'domain_name' '0'
+       option 'ntp_servers' '0'
+       option 'sip_server_address' '0'
+       option 'sip_server_domain_name' '0'
+       option 'nis_server_address' '0'
+       option 'nis_domain_name' '0'
+       option 'nisp_server_address' '0'
+       option 'nisp_domain_name' '0'
+       option 'bcmcs_server_address' '0'
+       option 'bcmcs_server_domain_name' '0'
+       
+       # Override the used DUID, by default it is derived from the interface MAC
+       # The given value must be uppercase and globally unique!
+       #option 'duid' '00:03:00:06:D8:5D:4C:A5:03:F2'
+
+       # Script to run when a reply is received
+       option 'script' '/usr/bin/dhcp6c-state'
+
+# Define one or more interfaces on which prefixes should be assigned
+config 'interface' 'loopback'
+       option 'enabled' '1'                            # 1 = enabled; 0 = disabled
+       option 'sla_id' '0'                             # Site level aggregator identifier specified in decimal (subnet)
+       option 'sla_len' '4'                            # Site level aggregator length (64 - size of prefix being delegated)
+                                                       # e.g. /60 from ISP -> 64 - 60 = 4
+
+config 'interface' 'lan'
+       option 'enabled' '1'
+       option 'sla_id' '1'
+       option 'sla_len' '4'
diff --git a/ipv6/wide-dhcpv6/files/dhcp6s.conf b/ipv6/wide-dhcpv6/files/dhcp6s.conf
deleted file mode 100644 (file)
index dda53d1..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-config 'dhcp6s' 'basic'
-       option 'enabled' '0'                            # 1 = enabled; 0 = disabled
-       option 'interface' 'lan'                        # This is the interface the DHCPv6 server will run on
-       option 'config_file' '/etc/dhcp6s.conf'         # Config file (as this UCI config doesn't fully support all options)
diff --git a/ipv6/wide-dhcpv6/files/dhcp6s.config b/ipv6/wide-dhcpv6/files/dhcp6s.config
new file mode 100644 (file)
index 0000000..dda53d1
--- /dev/null
@@ -0,0 +1,4 @@
+config 'dhcp6s' 'basic'
+       option 'enabled' '0'                            # 1 = enabled; 0 = disabled
+       option 'interface' 'lan'                        # This is the interface the DHCPv6 server will run on
+       option 'config_file' '/etc/dhcp6s.conf'         # Config file (as this UCI config doesn't fully support all options)